aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-flask-wtf.inc16
-rw-r--r--meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb17
2 files changed, 17 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-wtf.inc b/meta-python/recipes-devtools/python/python-flask-wtf.inc
new file mode 100644
index 0000000000..3a959aed73
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flask-wtf.inc
@@ -0,0 +1,16 @@
+DESCRIPTION = "Simple integration of Flask and WTForms."
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=507e8635f25a06dc4f041a3a1b3359b3"
+
+SRC_URI[md5sum] = "c53a74e8ba481bf53405fd5efdf0339e"
+SRC_URI[sha256sum] = "bd99316c97ed1d1cb90b8f0c242c86420a891a6a2058f20717e424bf5b0bb80e"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/python-flask-wtf:"
+SRC_URI += " file://import-simplejson-as-json.patch"
+
+PYPI_PACKAGE = "Flask-WTF"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-wtforms \
+ ${PYTHON_PN}-simplejson \
+"
diff --git a/meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb b/meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb
index 79afaf6595..dbf091bc0f 100644
--- a/meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb
+++ b/meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb
@@ -1,17 +1,2 @@
-DESCRIPTION = "Simple integration of Flask and WTForms."
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=507e8635f25a06dc4f041a3a1b3359b3"
-
-SRC_URI[md5sum] = "c53a74e8ba481bf53405fd5efdf0339e"
-SRC_URI[sha256sum] = "bd99316c97ed1d1cb90b8f0c242c86420a891a6a2058f20717e424bf5b0bb80e"
-
-SRC_URI += " file://import-simplejson-as-json.patch"
-
-PYPI_PACKAGE = "Flask-WTF"
-
inherit pypi setuptools
-
-RDEPENDS_${PN} = "\
- python-wtforms \
- python-simplejson \
-"
+require python-flask-wtf.inc