aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-toml.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-toml_0.10.0.bb6
-rw-r--r--meta-python/recipes-devtools/python/python3-toml_0.10.0.bb6
3 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-toml.inc b/meta-python/recipes-devtools/python/python-toml.inc
new file mode 100644
index 0000000000..a3b3dfc862
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-toml.inc
@@ -0,0 +1,10 @@
+SUMMARY = "Python Library for Tom's Obvious, Minimal Language"
+HOMEPAGE = "https://github.com/uiri/toml"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6d6012eea477117abf51c31262a152f8"
+
+SRC_URI[md5sum] = "63fffbe2d632865ec29cd69bfdf36682"
+SRC_URI[sha256sum] = "229f81c57791a41d65e399fc06bf0848bab550a9dfd5ed66df18ce5f05e73d5c"
+
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-toml_0.10.0.bb b/meta-python/recipes-devtools/python/python-toml_0.10.0.bb
new file mode 100644
index 0000000000..3c4acce678
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-toml_0.10.0.bb
@@ -0,0 +1,6 @@
+inherit setuptools
+require python-toml.inc
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+"
diff --git a/meta-python/recipes-devtools/python/python3-toml_0.10.0.bb b/meta-python/recipes-devtools/python/python3-toml_0.10.0.bb
new file mode 100644
index 0000000000..cebb41a533
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-toml_0.10.0.bb
@@ -0,0 +1,6 @@
+inherit setuptools3
+require python-toml.inc
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-misc \
+"