aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-pycurl.inc26
-rw-r--r--meta-python/recipes-devtools/python/python-pycurl_7.43.0.3.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pycurl_7.43.0.3.bb2
3 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycurl.inc b/meta-python/recipes-devtools/python/python-pycurl.inc
new file mode 100644
index 0000000000..ac9a370c4c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pycurl.inc
@@ -0,0 +1,26 @@
+SUMMARY = "A Python Interface To The cURL library"
+DESCRIPTION = "\
+PycURL is a Python interface to libcurl, the multiprotocol file \
+transfer library. Similarly to the urllib Python module, PycURL can \
+be used to fetch objects identified by a URL from a Python program \
+"
+SECTION = "devel/python"
+HOMEPAGE = "http://pycurl.io/"
+
+LICENSE = "LGPLv2 | MIT"
+LIC_FILES_CHKSUM = " \
+ file://COPYING-LGPL;md5=4fbd65380cdd255951079008b364516c \
+ file://COPYING-MIT;md5=2df767ed35d8ea83de4a93feb55e7815 \
+"
+
+SRC_URI[md5sum] = "f0ed4c805e8bec734990e2e0ee78568e"
+SRC_URI[sha256sum] = "6f08330c5cf79fa8ef68b9912b9901db7ffd34b63e225dce74db56bb21deda8e"
+
+inherit pypi
+
+PYPI_PACKAGE = "pycurl"
+
+DEPENDS = "\
+ curl \
+ ${PYTHON_PN}\
+"
diff --git a/meta-python/recipes-devtools/python/python-pycurl_7.43.0.3.bb b/meta-python/recipes-devtools/python/python-pycurl_7.43.0.3.bb
new file mode 100644
index 0000000000..7ab259265e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pycurl_7.43.0.3.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-pycurl.inc
diff --git a/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.3.bb b/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.3.bb
new file mode 100644
index 0000000000..5ad319ae2f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.3.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pycurl.inc