aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-pytest.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-pytest_3.4.2.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest_3.4.2.bb2
3 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest.inc b/meta-python/recipes-devtools/python/python-pytest.inc
index 4feb9a03cf..4c32dfb044 100644
--- a/meta-python/recipes-devtools/python/python-pytest.inc
+++ b/meta-python/recipes-devtools/python/python-pytest.inc
@@ -9,6 +9,8 @@ SRC_URI[sha256sum] = "117bad36c1a787e1a8a659df35de53ba05f9f3398fb9e4ac17e80ad590
SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch \
file://pytest_version_fix.patch "
+inherit update-alternatives
+
RDEPENDS_${PN}_class-target += " \
${PYTHON_PN}-attrs \
${PYTHON_PN}-debugger \
@@ -22,4 +24,12 @@ RDEPENDS_${PN}_class-target += " \
FILESEXTRAPATHS_prepend := "${THISDIR}/python-pytest:"
+ALTERNATIVE_${PN} += "py.test pytest"
+
+NATIVE_LINK_NAME[pytest] = "${bindir}/pytest"
+ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest"
+
+ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test"
+ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test"
+
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pytest_3.4.2.bb b/meta-python/recipes-devtools/python/python-pytest_3.4.2.bb
index 201ab050cd..39e50aca97 100644
--- a/meta-python/recipes-devtools/python/python-pytest_3.4.2.bb
+++ b/meta-python/recipes-devtools/python/python-pytest_3.4.2.bb
@@ -6,3 +6,4 @@ RDEPENDS_${PN}_class-target += " \
${PYTHON_PN}-compiler \
${PYTHON_PN}-funcsigs \
"
+ALTERNATIVE_PRIORITY = "10"
diff --git a/meta-python/recipes-devtools/python/python3-pytest_3.4.2.bb b/meta-python/recipes-devtools/python/python3-pytest_3.4.2.bb
index 466cfa8253..eba6632a27 100644
--- a/meta-python/recipes-devtools/python/python3-pytest_3.4.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest_3.4.2.bb
@@ -1,2 +1,4 @@
inherit pypi setuptools3
require python-pytest.inc
+
+ALTERNATIVE_PRIORITY = "100"