aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-support/netperf/netperf_2.6.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/netperf/netperf_2.6.0.bb b/meta-networking/recipes-support/netperf/netperf_2.6.0.bb
index 7124b02e3f..ffa77d7bb9 100644
--- a/meta-networking/recipes-support/netperf/netperf_2.6.0.bb
+++ b/meta-networking/recipes-support/netperf/netperf_2.6.0.bb
@@ -27,6 +27,9 @@ CFLAGS_append = " -DDO_UNIX -DDO_IPV6 -D_GNU_SOURCE"
CFLAGS_append = "${@base_contains('DISTRO_FEATURES', 'largefile', \
' -D_FILE_OFFSET_BITS=64', '', d)}"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[sctp] = "--enable-sctp,--disable-sctp,lksctp-tools,"
+
# autotools.bbclass attends to include m4 files with path depth <= 2 by
# "find ${S} -maxdepth 2 -name \*.m4", so move m4 files from m4/m4.
do_configure_prepend() {
@@ -57,5 +60,7 @@ do_install() {
install -m 0644 ${S}/doc/netperf_old.ps ${D}${docdir}/netperf
}
+RRECOMMENDS_${PN} += "${@base_contains('PACKAGECONFIG', 'sctp', 'kernel-module-sctp', '', d)}"
+
INITSCRIPT_NAME="netperf"
INITSCRIPT_PARAMS="defaults"