aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-pysocks.inc8
-rw-r--r--meta-python/recipes-devtools/python/python-pysocks_1.6.5.bb (renamed from meta-python/recipes-devtools/python/python-pysocks_1.5.7.bb)0
-rw-r--r--meta-python/recipes-devtools/python/python3-pysocks_1.5.7.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pysocks_1.6.5.bb8
4 files changed, 14 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python-pysocks.inc b/meta-python/recipes-devtools/python/python-pysocks.inc
index 0697fd7156..edf98fe19c 100644
--- a/meta-python/recipes-devtools/python/python-pysocks.inc
+++ b/meta-python/recipes-devtools/python/python-pysocks.inc
@@ -3,9 +3,13 @@ HOMEPAGE = "http://python-requests.org"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://LICENSE;md5=1d457bcffb9661b45f799d4efee72f16"
-SRC_URI[md5sum] = "68f4ad7a8d4fa725656ae3e9dd142d29"
-SRC_URI[sha256sum] = "e51c7694b10288e6fd9a28e15c0bcce9aca0327e7b32ebcd9af05fcd56f38b88"
+SRC_URI[md5sum] = "06524b15a3a96fe05212f12cfb87c57d"
+SRC_URI[sha256sum] = "7962f4d7c76e8414ae168c677a77f19cf8926143911f7e8d37a5d4c4eb910c6f"
PYPI_PACKAGE = "PySocks"
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-io \
+"
+
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pysocks_1.5.7.bb b/meta-python/recipes-devtools/python/python-pysocks_1.6.5.bb
index 8a24e4c49a..8a24e4c49a 100644
--- a/meta-python/recipes-devtools/python/python-pysocks_1.5.7.bb
+++ b/meta-python/recipes-devtools/python/python-pysocks_1.6.5.bb
diff --git a/meta-python/recipes-devtools/python/python3-pysocks_1.5.7.bb b/meta-python/recipes-devtools/python/python3-pysocks_1.5.7.bb
deleted file mode 100644
index 6b09355572..0000000000
--- a/meta-python/recipes-devtools/python/python3-pysocks_1.5.7.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-inherit pypi setuptools3
-require python-pysocks.inc
diff --git a/meta-python/recipes-devtools/python/python3-pysocks_1.6.5.bb b/meta-python/recipes-devtools/python/python3-pysocks_1.6.5.bb
new file mode 100644
index 0000000000..f8aa01be81
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pysocks_1.6.5.bb
@@ -0,0 +1,8 @@
+inherit pypi setuptools3
+require python-pysocks.inc
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-enum \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-selectors \
+"