aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/poco/poco/0001-Add-support-of-arch-riscv32.patch47
-rw-r--r--meta-oe/recipes-support/poco/poco/0001-fix-missing-expat-definition.patch27
-rw-r--r--meta-oe/recipes-support/poco/poco_1.11.0.bb (renamed from meta-oe/recipes-support/poco/poco_1.10.1.bb)6
3 files changed, 30 insertions, 50 deletions
diff --git a/meta-oe/recipes-support/poco/poco/0001-Add-support-of-arch-riscv32.patch b/meta-oe/recipes-support/poco/poco/0001-Add-support-of-arch-riscv32.patch
deleted file mode 100644
index e6b673b11d..0000000000
--- a/meta-oe/recipes-support/poco/poco/0001-Add-support-of-arch-riscv32.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 98d277655e411f56fba705c0bf2efc6562c23807 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sun, 15 Nov 2020 11:37:33 -0800
-Subject: [PATCH] Add support of arch riscv32
-
-Upstream-Status: Submitted [https://github.com/pocoproject/poco/pull/3138]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- Foundation/include/Poco/Platform.h | 13 +++++++++----
- 1 file changed, 9 insertions(+), 4 deletions(-)
-
-diff --git a/Foundation/include/Poco/Platform.h b/Foundation/include/Poco/Platform.h
-index 799db417e..b8506a248 100644
---- a/Foundation/include/Poco/Platform.h
-+++ b/Foundation/include/Poco/Platform.h
-@@ -135,6 +135,7 @@
- #define POCO_ARCH_AARCH64 0x0f
- #define POCO_ARCH_ARM64 0x0f // same as POCO_ARCH_AARCH64
- #define POCO_ARCH_RISCV64 0x10
-+#define POCO_ARCH_RISCV32 0x11
-
-
- #if defined(__ALPHA) || defined(__alpha) || defined(__alpha__) || defined(_M_ALPHA)
-@@ -225,12 +226,16 @@
- #elif defined(__AARCH64EB__)
- #define POCO_ARCH POCO_ARCH_AARCH64
- #define POCO_ARCH_BIG_ENDIAN 1
--#elif defined(__riscv) && (__riscv_xlen == 64)
-- #define POCO_ARCH POCO_ARCH_RISCV64
-- #define POCO_ARCH_LITTLE_ENDIAN 1
-+#elif defined(__riscv)
-+ #if (__riscv_xlen == 64)
-+ #define POCO_ARCH POCO_ARCH_RISCV64
-+ #define POCO_ARCH_LITTLE_ENDIAN 1
-+ #elif(__riscv_xlen == 32)
-+ #define POCO_ARCH POCO_ARCH_RISCV32
-+ #define POCO_ARCH_LITTLE_ENDIAN 1
-+ #endif
- #endif
-
--
- #if defined(__clang__)
- #define POCO_COMPILER_CLANG
- #elif defined(_MSC_VER)
---
-2.29.2
-
diff --git a/meta-oe/recipes-support/poco/poco/0001-fix-missing-expat-definition.patch b/meta-oe/recipes-support/poco/poco/0001-fix-missing-expat-definition.patch
new file mode 100644
index 0000000000..625aa31911
--- /dev/null
+++ b/meta-oe/recipes-support/poco/poco/0001-fix-missing-expat-definition.patch
@@ -0,0 +1,27 @@
+From 3f288fefbd683d687bde3fc63964da64bc3c8a40 Mon Sep 17 00:00:00 2001
+From: Pascal Bach <pascal.bach@siemens.com>
+Date: Wed, 11 Aug 2021 15:11:49 +0200
+Subject: [PATCH] fix missing expat definition
+
+Upstream-Status: Submitted [https://github.com/pocoproject/poco/pull/3414]
+Signed-off-by: Pascal Bach <pascal.bach@siemens.com>
+---
+ XML/src/ParserEngine.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/XML/src/ParserEngine.cpp b/XML/src/ParserEngine.cpp
+index 82d477478..6213e555b 100644
+--- a/XML/src/ParserEngine.cpp
++++ b/XML/src/ParserEngine.cpp
+@@ -504,7 +504,7 @@ void ParserEngine::init()
+ XML_SetParamEntityParsing(_parser, _externalParameterEntities ? XML_PARAM_ENTITY_PARSING_ALWAYS : XML_PARAM_ENTITY_PARSING_NEVER);
+ XML_SetUnknownEncodingHandler(_parser, handleUnknownEncoding, this);
+
+-#if XML_MAJOR_VERSION > 2 || (XML_MAJOR_VERSION == 2 && XML_MINOR_VERSION >= 4)
++#if XML_DTD && (XML_MAJOR_VERSION > 2 || (XML_MAJOR_VERSION == 2 && XML_MINOR_VERSION >= 4))
+ if (_maximumAmplificationFactor > 1.0)
+ {
+ XML_SetBillionLaughsAttackProtectionMaximumAmplification(_parser, _maximumAmplificationFactor);
+--
+2.32.0
+
diff --git a/meta-oe/recipes-support/poco/poco_1.10.1.bb b/meta-oe/recipes-support/poco/poco_1.11.0.bb
index 5db518cbba..5f63910983 100644
--- a/meta-oe/recipes-support/poco/poco_1.10.1.bb
+++ b/meta-oe/recipes-support/poco/poco_1.11.0.bb
@@ -9,11 +9,11 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4267f48fc738f50380cbeeb76f95cebc"
DEPENDS = "libpcre zlib"
SRC_URI = " \
- git://github.com/pocoproject/poco.git;branch=poco-${PV} \
- file://0001-Add-support-of-arch-riscv32.patch \
+ git://github.com/pocoproject/poco.git;branch=master \
+ file://0001-fix-missing-expat-definition.patch \
file://run-ptest \
"
-SRCREV = "a3d827d80eb7f3329c58e73eb2906cb7ba829019"
+SRCREV = "f81a38057f1d240fe7b7a069612776f788bc88ea"
UPSTREAM_CHECK_GITTAGREGEX = "poco-(?P<pver>\d+(\.\d+)+)"