aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xmeta-networking/recipes-daemons/vsftpd/files/init (renamed from meta-oe/recipes-connectivity/vsftpd/files/init)0
-rwxr-xr-xmeta-networking/recipes-daemons/vsftpd/files/vsftpd.conf (renamed from meta-oe/recipes-connectivity/vsftpd/files/vsftpd.conf)0
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-destdir.patch (renamed from meta-oe/recipes-connectivity/vsftpd/vsftpd-2.3.5/makefile.patch)25
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-libs.patch21
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-strip.patch17
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/nopam.patch (renamed from meta-oe/recipes-connectivity/vsftpd/vsftpd-2.3.5/nopam.patch)4
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd_2.3.5.bb (renamed from meta-oe/recipes-connectivity/vsftpd/vsftpd_2.3.5.bb)17
7 files changed, 63 insertions, 21 deletions
diff --git a/meta-oe/recipes-connectivity/vsftpd/files/init b/meta-networking/recipes-daemons/vsftpd/files/init
index d0ec010dc7..d0ec010dc7 100755
--- a/meta-oe/recipes-connectivity/vsftpd/files/init
+++ b/meta-networking/recipes-daemons/vsftpd/files/init
diff --git a/meta-oe/recipes-connectivity/vsftpd/files/vsftpd.conf b/meta-networking/recipes-daemons/vsftpd/files/vsftpd.conf
index 08f91e048d..08f91e048d 100755
--- a/meta-oe/recipes-connectivity/vsftpd/files/vsftpd.conf
+++ b/meta-networking/recipes-daemons/vsftpd/files/vsftpd.conf
diff --git a/meta-oe/recipes-connectivity/vsftpd/vsftpd-2.3.5/makefile.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-destdir.patch
index 3bf8f97671..ee37f26e9f 100644
--- a/meta-oe/recipes-connectivity/vsftpd/vsftpd-2.3.5/makefile.patch
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-destdir.patch
@@ -1,17 +1,14 @@
-diff -ur vsftpd-2.0.1_org/Makefile vsftpd-2.0.1_patch/Makefile
---- vsftpd-2.0.1_org/Makefile 2004-06-06 18:21:27.000000000 +0200
-+++ vsftpd-2.0.1_patch/Makefile 2004-07-21 09:50:25.245576352 +0200
-@@ -5,7 +5,7 @@
- #CFLAGS = -g
- CFLAGS = -O2 -Wall -W -Wshadow #-pedantic -Werror -Wconversion
-
--LIBS = `./vsf_findlibs.sh`
-+LIBS = -lssl -lcrypto -lnsl -lresolv
- LINK = -Wl,-s
-
- OBJS = main.o utility.o prelogin.o ftpcmdio.o postlogin.o privsock.o \
-@@ -24,21 +24,21 @@
- $(CC) -o vsftpd $(OBJS) $(LINK) $(LIBS)
+Use DESTDIR within install to allow installing under a prefix
+
+Upstream-Status: Pending
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+diff --git a/Makefile b/Makefile
+--- a/Makefile
++++ b/Makefile
+@@ -24,21 +24,21 @@ vsftpd: $(OBJS)
+ $(CC) -o vsftpd $(OBJS) $(LINK) $(LIBS) $(LDFLAGS)
install:
- if [ -x /usr/local/sbin ]; then \
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-libs.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-libs.patch
new file mode 100644
index 0000000000..6a419db477
--- /dev/null
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-libs.patch
@@ -0,0 +1,21 @@
+Hardcode LIBS instead of using a script to determine available libs
+
+We want to avoid this dynamic detection so we have a deterministic
+build.
+
+Upstream-Status: Inappropriate [config]
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+diff --git a/Makefile b/Makefile
+--- a/Makefile
++++ b/Makefile
+@@ -5,7 +5,7 @@ IFLAGS = -idirafter dummyinc
+ #CFLAGS = -g
+ CFLAGS = -O2 -Wall -W -Wshadow #-pedantic -Werror -Wconversion
+
+-LIBS = `./vsf_findlibs.sh`
++LIBS = -lssl -lcrypto -lnsl -lresolv
+ LINK = -Wl,-s
+
+ OBJS = main.o utility.o prelogin.o ftpcmdio.o postlogin.o privsock.o \
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-strip.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-strip.patch
new file mode 100644
index 0000000000..a2e0cd048f
--- /dev/null
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-strip.patch
@@ -0,0 +1,17 @@
+Disable stripping at link time
+
+Upstream-Status: Inappropriate [config]
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+diff --git a/Makefile b/Makefile
+--- a/Makefile
++++ b/Makefile
+@@ -6,7 +6,6 @@ IFLAGS = -idirafter dummyinc
+ CFLAGS = -O2 -Wall -W -Wshadow #-pedantic -Werror -Wconversion
+
+ LIBS = -lssl -lcrypto -lnsl -lresolv
+-LINK = -Wl,-s
+
+ OBJS = main.o utility.o prelogin.o ftpcmdio.o postlogin.o privsock.o \
+ tunables.o ftpdataio.o secbuf.o ls.o \
diff --git a/meta-oe/recipes-connectivity/vsftpd/vsftpd-2.3.5/nopam.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/nopam.patch
index 8e0559cad1..cf0d68e272 100644
--- a/meta-oe/recipes-connectivity/vsftpd/vsftpd-2.3.5/nopam.patch
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/nopam.patch
@@ -1,3 +1,7 @@
+Disable PAM
+
+Upstream-Status: Inappropriate [config]
+
diff -ur vsftpd-2.0.1_org/builddefs.h vsftpd-2.0.1_patch/builddefs.h
--- vsftpd-2.0.1_org/builddefs.h 2004-07-02 16:36:59.000000000 +0200
+++ vsftpd-2.0.1_patch/builddefs.h 2004-07-21 09:34:49.044900488 +0200
diff --git a/meta-oe/recipes-connectivity/vsftpd/vsftpd_2.3.5.bb b/meta-networking/recipes-daemons/vsftpd/vsftpd_2.3.5.bb
index 1669d96f8c..c02ee9c0ab 100644
--- a/meta-oe/recipes-connectivity/vsftpd/vsftpd_2.3.5.bb
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd_2.3.5.bb
@@ -1,17 +1,22 @@
-DESCRIPTION = "Secure ftp server"
-HOMEPAGE="https://security.appspot.com/vsftpd.html"
+SUMMARY = "Very Secure FTP server"
+HOMEPAGE = "https://security.appspot.com/vsftpd.html"
SECTION = "network"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=a6067ad950b28336613aed9dd47b1271"
DEPENDS = "libcap"
-SRC_URI = "https://security.appspot.com/downloads/vsftpd-2.3.5.tar.gz \
- file://makefile.patch \
+SRC_URI = "https://security.appspot.com/downloads/vsftpd-${PV}.tar.gz \
+ file://makefile-destdir.patch \
+ file://makefile-libs.patch \
+ file://makefile-strip.patch \
file://nopam.patch \
file://init \
file://vsftpd.conf"
+SRC_URI[md5sum] = "01398a5bef8e85b6cf2c213a4b011eca"
+SRC_URI[sha256sum] = "d87ee2987df8f03e1dbe294905f7907b2798deb89c67ca965f6e2f60879e54f1"
+
inherit update-rc.d useradd
CONFFILES_${PN} = "${sysconfdir}/vsftpd.conf"
@@ -43,6 +48,4 @@ USERADD_PACKAGES = "${PN}"
USERADD_PARAM_${PN} = "--system --home-dir /var/lib/ftp --no-create-home -g ftp \
--shell /bin/false ftp "
GROUPADD_PARAM_${PN} = "-r ftp"
-
-SRC_URI[md5sum] = "01398a5bef8e85b6cf2c213a4b011eca"
-SRC_URI[sha256sum] = "d87ee2987df8f03e1dbe294905f7907b2798deb89c67ca965f6e2f60879e54f1"
+