aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/postgresql/postgresql-9.2.4/ecpg-parallel-make-fix.patch31
-rw-r--r--meta-oe/recipes-support/postgresql/postgresql_9.2.4.bb5
2 files changed, 35 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/postgresql/postgresql-9.2.4/ecpg-parallel-make-fix.patch b/meta-oe/recipes-support/postgresql/postgresql-9.2.4/ecpg-parallel-make-fix.patch
new file mode 100644
index 0000000000..63615cd517
--- /dev/null
+++ b/meta-oe/recipes-support/postgresql/postgresql-9.2.4/ecpg-parallel-make-fix.patch
@@ -0,0 +1,31 @@
+Upstream-status: backport
+
+From 602070f9cce790debd8d1469254e7726ab499ae7 Mon Sep 17 00:00:00 2001
+From: Peter Eisentraut <peter_e@gmx.net>
+Date: Fri, 29 Mar 2013 21:39:55 -0400
+Subject: [PATCH] ecpg: Parallel make fix
+
+In some parallel make situations, the install-headers target could be
+called before the installation directories are created by installdirs,
+causing the installation to fail. Fix that by making install-headers
+depend on installdirs.
+---
+ src/interfaces/ecpg/include/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/interfaces/ecpg/include/Makefile b/src/interfaces/ecpg/include/Makefile
+index eab833b..e92e56f 100644
+--- a/src/interfaces/ecpg/include/Makefile
++++ b/src/interfaces/ecpg/include/Makefile
+@@ -18,7 +18,7 @@ ecpg_headers = ecpgerrno.h ecpglib.h ecpgtype.h sqlca.h sql3types.h ecpg_informi
+ sqlda.h sqlda-compat.h sqlda-native.h
+ informix_headers = datetime.h decimal.h sqltypes.h
+
+-install-headers: $(ecpg_headers) $(informix_headers)
++install-headers: $(ecpg_headers) $(informix_headers) installdirs
+ $(INSTALL_DATA) $(addprefix $(srcdir)/,$(ecpg_headers)) '$(DESTDIR)$(includedir)/'
+ $(INSTALL_DATA) $(addprefix $(srcdir)/,$(informix_headers)) '$(DESTDIR)$(informix_esql_dir)/'
+ $(INSTALL_DATA) $(ecpg_config_h) '$(DESTDIR)$(includedir)'
+--
+1.8.3.4
+
diff --git a/meta-oe/recipes-support/postgresql/postgresql_9.2.4.bb b/meta-oe/recipes-support/postgresql/postgresql_9.2.4.bb
index 59665daf1f..49ca53fae3 100644
--- a/meta-oe/recipes-support/postgresql/postgresql_9.2.4.bb
+++ b/meta-oe/recipes-support/postgresql/postgresql_9.2.4.bb
@@ -4,7 +4,10 @@ LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=ab55a5887d3f8ba77d0fd7db787e4bab"
PR = "${INC_PR}.0"
-SRC_URI += "file://remove.autoconf.version.check.patch"
+SRC_URI += "\
+ file://remove.autoconf.version.check.patch \
+ file://ecpg-parallel-make-fix.patch \
+"
SRC_URI[md5sum] = "6ee5bb53b97da7c6ad9cb0825d3300dd"
SRC_URI[sha256sum] = "d97dd918a88a4449225998f46aafa85216a3f89163a3411830d6890507ffae93"