aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/php/php-5.6.26/CVE-2017-9227.patch24
-rw-r--r--meta-oe/recipes-devtools/php/php_5.6.26.bb1
2 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/php/php-5.6.26/CVE-2017-9227.patch b/meta-oe/recipes-devtools/php/php-5.6.26/CVE-2017-9227.patch
new file mode 100644
index 0000000000..432bd3b43e
--- /dev/null
+++ b/meta-oe/recipes-devtools/php/php-5.6.26/CVE-2017-9227.patch
@@ -0,0 +1,24 @@
+commit 9690d3ab1f9bcd2db8cbe1fe3ee4a5da606b8814
+Author: K.Kosako <kosako@sofnec.co.jp>
+Date: Tue May 23 16:15:35 2017 +0900
+
+ fix #58 : access to invalid address by reg->dmin value
+
+Upstream-Status: Backport
+
+CVE: CVE-2017-9227
+Signed-off-by: Thiruvadi Rajaraman <trajaraman@mvista.com>
+
+Index: php-5.6.26/ext/mbstring/oniguruma/regexec.c
+===================================================================
+--- php-5.6.26.orig/ext/mbstring/oniguruma/regexec.c 2016-09-16 02:32:50.000000000 +0530
++++ php-5.6.26/ext/mbstring/oniguruma/regexec.c 2017-08-30 12:49:07.164967788 +0530
+@@ -3128,6 +3128,8 @@
+ }
+ else {
+ UChar *q = p + reg->dmin;
++
++ if (q >= end) return 0; /* fail */
+ while (p < q) p += enclen(reg->enc, p);
+ }
+ }
diff --git a/meta-oe/recipes-devtools/php/php_5.6.26.bb b/meta-oe/recipes-devtools/php/php_5.6.26.bb
index a10d2a6bc1..3a383381f7 100644
--- a/meta-oe/recipes-devtools/php/php_5.6.26.bb
+++ b/meta-oe/recipes-devtools/php/php_5.6.26.bb
@@ -7,6 +7,7 @@ SRC_URI += "file://change-AC_TRY_RUN-to-AC_TRY_LINK.patch \
file://CVE-2016-9934.patch \
file://CVE-2016-9935.patch \
file://CVE-2016-9933.patch \
+ file://CVE-2017-9227.patch \
"
SRC_URI[md5sum] = "cb424b705cfb715fc04f499f8a8cf52e"
SRC_URI[sha256sum] = "d47aab8083a4284b905777e1b45dd7735adc53be827b29f896684750ac8b6236"