aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain-layer
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-08-28 06:34:10 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-09-03 19:56:52 +0200
commit9f26a42638fda6159bf2a68f1db32db1eb72c355 (patch)
tree5364fddfbc6f1498bdc32cff4aee95e651edbb17 /toolchain-layer
parent0879762ec4206333173d6a0abaa21f1398bac2a4 (diff)
downloadmeta-openembedded-contrib-9f26a42638fda6159bf2a68f1db32db1eb72c355.tar.gz
gcc-4.6: Update to match gcc restructing in OE-Core
The include file infra in gcc recipes recieved an overhaul on OE-Core. This patch matches the toolchain layer recipes to use the new include files Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'toolchain-layer')
-rw-r--r--toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb19
-rw-r--r--toolchain-layer/recipes-devtools/gcc/gcc-cross_4.6.bb8
-rw-r--r--toolchain-layer/recipes-devtools/gcc/gcc-runtime_4.6.bb8
-rw-r--r--toolchain-layer/recipes-devtools/gcc/gcc_4.6.bb5
4 files changed, 3 insertions, 37 deletions
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb b/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb
index 5c2435fc9a..29ddd67735 100644
--- a/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb
+++ b/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb
@@ -2,22 +2,3 @@ inherit cross-canadian
require recipes-devtools/gcc/gcc-${PV}.inc
require recipes-devtools/gcc/gcc-cross-canadian.inc
-require recipes-devtools/gcc/gcc-configure-sdk.inc
-require recipes-devtools/gcc/gcc-package-sdk.inc
-
-DEPENDS += "nativesdk-gmp nativesdk-mpfr nativesdk-libmpc nativesdk-elfutils"
-RDEPENDS_${PN} += "nativesdk-mpfr nativesdk-libmpc nativesdk-elfutils"
-
-SYSTEMHEADERS = "/usr/include"
-SYSTEMLIBS = "/lib/"
-SYSTEMLIBS1 = "/usr/lib/"
-
-EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
- --disable-libgomp --disable-libmudflap \
- --with-mpfr=${STAGING_DIR_HOST}${layout_exec_prefix} \
- --with-mpc=${STAGING_DIR_HOST}${layout_exec_prefix}"
-
-# to find libmpfr
-# export LD_LIBRARY_PATH = "{STAGING_DIR_HOST}${layout_exec_prefix}"
-
-PARALLEL_MAKE = ""
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-cross_4.6.bb b/toolchain-layer/recipes-devtools/gcc/gcc-cross_4.6.bb
index eb8896ca51..cdaa7e8cd3 100644
--- a/toolchain-layer/recipes-devtools/gcc/gcc-cross_4.6.bb
+++ b/toolchain-layer/recipes-devtools/gcc/gcc-cross_4.6.bb
@@ -1,8 +1,2 @@
require recipes-devtools/gcc/gcc-${PV}.inc
-require recipes-devtools/gcc/gcc-cross4.inc
-
-EXTRA_OECONF += "--disable-libunwind-exceptions \
- --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} \
- --with-system-zlib "
-
-ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"
+require recipes-devtools/gcc/gcc-cross.inc
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-runtime_4.6.bb b/toolchain-layer/recipes-devtools/gcc/gcc-runtime_4.6.bb
index 13431c8b66..b755f555ef 100644
--- a/toolchain-layer/recipes-devtools/gcc/gcc-runtime_4.6.bb
+++ b/toolchain-layer/recipes-devtools/gcc/gcc-runtime_4.6.bb
@@ -1,8 +1,2 @@
require recipes-devtools/gcc/gcc-${PV}.inc
-require recipes-devtools/gcc/gcc-configure-runtime.inc
-require recipes-devtools/gcc/gcc-package-runtime.inc
-
-ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
-
-EXTRA_OECONF += "--disable-libunwind-exceptions"
-EXTRA_OECONF_append_linuxstdbase = " --enable-clocale=gnu"
+require recipes-devtools/gcc/gcc-runtime.inc
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc_4.6.bb b/toolchain-layer/recipes-devtools/gcc/gcc_4.6.bb
index 97e6c324de..6ad8973b43 100644
--- a/toolchain-layer/recipes-devtools/gcc/gcc_4.6.bb
+++ b/toolchain-layer/recipes-devtools/gcc/gcc_4.6.bb
@@ -1,5 +1,2 @@
require recipes-devtools/gcc/gcc-${PV}.inc
-require recipes-devtools/gcc/gcc-configure-target.inc
-require recipes-devtools/gcc/gcc-package-target.inc
-
-ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
+require recipes-devtools/gcc/gcc-target.inc