aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-support/multipath-tools/multipath-tools_git.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2013-03-27 19:31:02 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-03-29 13:16:39 +0100
commit74eee8a7960cf0a898d795cb024b10a58357dbcd (patch)
tree7257b890850005961ff8d8f7168caefdbb71976e /recipes-support/multipath-tools/multipath-tools_git.bb
parent5537394821c750ed82e01d3eea8659878785869e (diff)
downloadmeta-openembedded-contrib-74eee8a7960cf0a898d795cb024b10a58357dbcd.tar.gz
multipath-tools: add recipe for git version
Multipath-tools hasn't seen a release in 3 years, so grab latest git. 'kpartx' is subpackaged since that's the tool most people want. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-support/multipath-tools/multipath-tools_git.bb')
-rw-r--r--recipes-support/multipath-tools/multipath-tools_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-support/multipath-tools/multipath-tools_git.bb b/recipes-support/multipath-tools/multipath-tools_git.bb
new file mode 100644
index 0000000000..808bc28789
--- /dev/null
+++ b/recipes-support/multipath-tools/multipath-tools_git.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "The upstream project used to drive the Device Mapper multipathing driver."
+
+DEPENDS = "lvm2 libaio readline"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=7be2873b6270e45abacc503abbe2aa3d"
+
+
+SRC_URI = "git://git.opensvc.com/multipath-tools/.git;protocol=http"
+SRCREV = "15fc23ffb2bd1bac6990eda3e23c3e8980e6cfa5"
+
+S = "${WORKDIR}/git"
+
+PV = "0.4.9+git"
+
+EXTRA_OEMAKE = "MULTIPATH_VERSION=${PV} DESTDIR=${D} syslibdir=${base_libdir} libdir=${base_libdir}/multipath"
+
+do_install() {
+ oe_runmake install
+}
+
+FILES_${PN}-dbg += "${base_libdir}/multipath/.debug"
+FILES_${PN} += "${base_libdir}/multipath \
+ ${base_libdir}/systemd"
+
+PACKAGES =+ "kpartx"
+FILES_kpartx = "${base_sbindir}/kpartx \
+ ${base_libdir}/udev/kpartx_id"
+
+RDEPENDS_${PN} += "kpartx"