aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-numpy_1.4.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-01-13 21:20:46 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-01-13 21:22:06 +0100
commitfbf853f629b3dcbee4d16669aec727c84903169e (patch)
tree5a1ac9f6521c4cb7466602003773b9b59a1101fa /recipes-devtools/python/python-numpy_1.4.1.bb
parentcbe66021c51aceee7c15938b2759efc1a79c654c (diff)
downloadmeta-openembedded-contrib-fbf853f629b3dcbee4d16669aec727c84903169e.tar.gz
python-numpy: import from OE
Currently doesn't build Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-devtools/python/python-numpy_1.4.1.bb')
-rw-r--r--recipes-devtools/python/python-numpy_1.4.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-numpy_1.4.1.bb b/recipes-devtools/python/python-numpy_1.4.1.bb
new file mode 100644
index 0000000000..ed47f47db1
--- /dev/null
+++ b/recipes-devtools/python/python-numpy_1.4.1.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "A sophisticated Numeric Processing Package for Python"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3c42211d73c3faa1026e671dd39883fa"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
+ file://config.h \
+ file://numpyconfig.h \
+ "
+
+S = "${WORKDIR}/numpy-${PV}"
+
+inherit distutils
+
+# Make the build fail and replace *config.h with proper one
+# This is a ugly, ugly hack - Koen
+do_compile_prepend() {
+ BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+ ${STAGING_BINDIR_NATIVE}/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
+ true
+ cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/
+}
+
+SRC_URI[md5sum] = "5c7b5349dc3161763f7f366ceb96516b"
+SRC_URI[sha256sum] = "2e7bb84573e5123e07f3c919fd433bc09b78d606252b6b719e385c2a981d8e06"