aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2019-05-28 22:40:39 -0400
committerKhem Raj <raj.khem@gmail.com>2019-05-29 02:21:42 -0700
commit0e837dad4ba64ba64b42a3b30dffe68a440e46e6 (patch)
tree844a2ab711a94888f0bb187074d31f3ee5023c90 /meta-xfce
parente9ffb7c6c09b9a7ca52801fb27dd1a057d15f7c1 (diff)
downloadmeta-openembedded-contrib-0e837dad4ba64ba64b42a3b30dffe68a440e46e6.tar.gz
lxdm: provides fake gdmflexiserver for xfce desktop environment
Xfce4 plugin 'actions' which stays in tray area provides a menu 'Switch User' but the menu grayed out. It calls whether 'dm-tool' from lightdm or 'gdmflexiserver' from gdm to support switch users. Since recipe gdm has been removed from meta-gnome, create a fake 'gdmflexiserver' which calls lxdm to make menu 'Switch User' work according to: https://wiki.archlinux.org/index.php/Xfce#User_switching_action_button_is_greyed_out Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-graphics/lxdm/lxdm/gdmflexiserver3
-rw-r--r--meta-xfce/recipes-graphics/lxdm/lxdm_%.bbappend7
2 files changed, 10 insertions, 0 deletions
diff --git a/meta-xfce/recipes-graphics/lxdm/lxdm/gdmflexiserver b/meta-xfce/recipes-graphics/lxdm/lxdm/gdmflexiserver
new file mode 100644
index 0000000000..4ef8baf29d
--- /dev/null
+++ b/meta-xfce/recipes-graphics/lxdm/lxdm/gdmflexiserver
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+lxdm -c USER_SWITCH
diff --git a/meta-xfce/recipes-graphics/lxdm/lxdm_%.bbappend b/meta-xfce/recipes-graphics/lxdm/lxdm_%.bbappend
new file mode 100644
index 0000000000..4a799a98af
--- /dev/null
+++ b/meta-xfce/recipes-graphics/lxdm/lxdm_%.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS_append := "${THISDIR}/${BPN}:"
+
+SRC_URI += "file://gdmflexiserver"
+
+do_install_append () {
+ install -D -m 0755 ${WORKDIR}/gdmflexiserver ${D}${bindir}/gdmflexiserver
+}