aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2020-11-19 15:41:31 +0800
committerKhem Raj <raj.khem@gmail.com>2020-11-19 07:36:26 -0800
commitaffc550278ca10c2a76acc67483ff471073d76ee (patch)
tree9da9b7be308959f86ac0ce8f7183c41ad55b7a5e /meta-xfce
parentfc224bdf8ea5e80fc038d656cad5671fb9baa486 (diff)
downloadmeta-openembedded-contrib-affc550278ca10c2a76acc67483ff471073d76ee.tar.gz
xfce4-cpufreq-plugin: 1.2.1 -> 1.2.2
1.2.2 - Update URLs and copyright year - Add basic GitLab pipeline - Fix compilation with gcc-10 - Update URLs from goodies.x.o to docs.x.o (Bug #16156) - s/http/https - Fix build with panel 4.15 - Replace GtkStock buttons - Rename applet to plugin (Bug #15582) - Post release tag bump - Translation Updates Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/0001-Fix-memory-leak-and-reduce-cpu-load-slightly.patch6
-rw-r--r--meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.1-gcc10-common.patch26
-rw-r--r--meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.2.2.bb (renamed from meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.2.1.bb)4
3 files changed, 22 insertions, 14 deletions
diff --git a/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/0001-Fix-memory-leak-and-reduce-cpu-load-slightly.patch b/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/0001-Fix-memory-leak-and-reduce-cpu-load-slightly.patch
index 92a6e8384d..ae8bc5279d 100644
--- a/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/0001-Fix-memory-leak-and-reduce-cpu-load-slightly.patch
+++ b/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/0001-Fix-memory-leak-and-reduce-cpu-load-slightly.patch
@@ -18,6 +18,7 @@ Upstream-Status: Submitted [1]
[1] https://bugzilla.xfce.org/attachment.cgi?id=8492
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+
---
panel-plugin/xfce4-cpufreq-configure.c | 4 ++++
panel-plugin/xfce4-cpufreq-plugin.c | 13 +++++++++++--
@@ -109,13 +110,12 @@ index a6895e4..6338698 100644
+++ b/panel-plugin/xfce4-cpufreq-plugin.h
@@ -95,6 +95,8 @@ typedef struct
- CpuFreqPlugin *cpuFreq;
+ extern CpuFreqPlugin *cpuFreq;
+GtkCssProvider *currentProvider;
+
G_BEGIN_DECLS
void
---
+---
2.20.1
-
diff --git a/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.1-gcc10-common.patch b/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.1-gcc10-common.patch
index d5238d00ff..95605f83ae 100644
--- a/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.1-gcc10-common.patch
+++ b/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.1-gcc10-common.patch
@@ -5,26 +5,34 @@ Part of Patch from https://src.fedoraproject.org/rpms/xfce4-cpufreq-plugin/raw/m
Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Refresh for xfce4-cpufreq-plugin 1.2.2.
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+
+---
+ panel-plugin/xfce4-cpufreq-plugin.c | 1 +
+ panel-plugin/xfce4-cpufreq-plugin.h | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/panel-plugin/xfce4-cpufreq-plugin.c b/panel-plugin/xfce4-cpufreq-plugin.c
+index 1e33492..ce9e302 100644
--- a/panel-plugin/xfce4-cpufreq-plugin.c
+++ b/panel-plugin/xfce4-cpufreq-plugin.c
-@@ -37,7 +37,8 @@
- #include "xfce4-cpufreq-linux.h"
+@@ -38,6 +38,7 @@
#endif /* __linux__ */
--
-+CpuFreqPlugin *cpuFreq;
+ CpuFreqPlugin *cpuFreq;
+GtkCssProvider *currentProvider;
void
cpufreq_label_set_font (void)
+diff --git a/panel-plugin/xfce4-cpufreq-plugin.h b/panel-plugin/xfce4-cpufreq-plugin.h
+index 8cd0d33..7dbccef 100644
--- a/panel-plugin/xfce4-cpufreq-plugin.h
+++ b/panel-plugin/xfce4-cpufreq-plugin.h
-@@ -93,9 +93,9 @@ typedef struct
- gint timeoutHandle;
- } CpuFreqPlugin;
+@@ -95,7 +95,7 @@ typedef struct
--CpuFreqPlugin *cpuFreq;
-+extern CpuFreqPlugin *cpuFreq;
+ extern CpuFreqPlugin *cpuFreq;
-GtkCssProvider *currentProvider;
+extern GtkCssProvider *currentProvider;
diff --git a/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.2.1.bb b/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.2.2.bb
index 5dce51b925..3b7b9ec5da 100644
--- a/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.2.1.bb
+++ b/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.2.2.bb
@@ -5,8 +5,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1f6f1c0be32491a0c8d2915607a28f36"
inherit xfce-panel-plugin
-SRC_URI[md5sum] = "ccd8f0f7aef51bc4caf1049986d9614f"
-SRC_URI[sha256sum] = "c5e044c0dc401d2066f208a3df82a588b3e51ff01425f155d0a1d0f8fce8f5b5"
+SRC_URI[sha256sum] = "500f04b8d857c96da8c8c7a4eecba30a903d0fce6e35a05e674529e43b47e498"
+
SRC_URI += "file://0001-Fix-memory-leak-and-reduce-cpu-load-slightly.patch \
file://xfce4-cpufreq-plugin-1.2.1-gcc10-common.patch \
"