aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-07-13 22:40:04 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-24 18:57:34 +0200
commit0cb5343932bdd4df2629d41f16a471a611fdfa2e (patch)
tree3fb76915c523942f3eca59c7cca89de941d12cea /meta-xfce
parent43022b71013e4fd992a7b381d70dea2df59de127 (diff)
downloadmeta-openembedded-contrib-0cb5343932bdd4df2629d41f16a471a611fdfa2e.tar.gz
imsettings: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-extended/imsettings/imsettings/0001-Rename-use-of-stdout-and-stderr.patch72
-rw-r--r--meta-xfce/recipes-extended/imsettings/imsettings_1.7.2.bb4
2 files changed, 75 insertions, 1 deletions
diff --git a/meta-xfce/recipes-extended/imsettings/imsettings/0001-Rename-use-of-stdout-and-stderr.patch b/meta-xfce/recipes-extended/imsettings/imsettings/0001-Rename-use-of-stdout-and-stderr.patch
new file mode 100644
index 0000000000..d77ce4d25d
--- /dev/null
+++ b/meta-xfce/recipes-extended/imsettings/imsettings/0001-Rename-use-of-stdout-and-stderr.patch
@@ -0,0 +1,72 @@
+From 7ee62ef0083844ab2fffcd106e3ee2e5f29b2a91 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 12 Jul 2017 18:53:56 -0700
+Subject: [PATCH] Rename use of stdout and stderr
+
+Since it shadow the standard definitions especially
+seen on musl where libc defines these as macros they
+cause all short of compilation errors on musl, using
+a leading underscore makes it unique
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ imsettings-daemon/imsettings-proc.c | 28 ++++++++++++++--------------
+ 1 file changed, 14 insertions(+), 14 deletions(-)
+
+diff --git a/imsettings-daemon/imsettings-proc.c b/imsettings-daemon/imsettings-proc.c
+index 915e78b..b78fcff 100644
+--- a/imsettings-daemon/imsettings-proc.c
++++ b/imsettings-daemon/imsettings-proc.c
+@@ -39,8 +39,8 @@
+ #define MAXRESTART 3
+
+ typedef struct _IMSettingsProcInfo {
+- GIOChannel *stdout;
+- GIOChannel *stderr;
++ GIOChannel *_stdout;
++ GIOChannel *_stderr;
+ GPid pid;
+ GTimeVal started_time;
+ guint id;
+@@ -368,12 +368,12 @@ _start_process(IMSettingsProc *proc,
+ &ofd, &efd,
+ error)) {
+ pinfo->pid = pid;
+- pinfo->stdout = g_io_channel_unix_new(ofd);
+- pinfo->stderr = g_io_channel_unix_new(efd);
+- g_io_channel_set_close_on_unref(pinfo->stdout, TRUE);
+- g_io_channel_set_close_on_unref(pinfo->stderr, TRUE);
+- pinfo->oid = g_io_add_watch(pinfo->stdout, G_IO_IN, _log_write_cb, proc);
+- pinfo->eid = g_io_add_watch(pinfo->stderr, G_IO_IN, _log_write_cb, proc);
++ pinfo->_stdout = g_io_channel_unix_new(ofd);
++ pinfo->_stderr = g_io_channel_unix_new(efd);
++ g_io_channel_set_close_on_unref(pinfo->_stdout, TRUE);
++ g_io_channel_set_close_on_unref(pinfo->_stderr, TRUE);
++ pinfo->oid = g_io_add_watch(pinfo->_stdout, G_IO_IN, _log_write_cb, proc);
++ pinfo->eid = g_io_add_watch(pinfo->_stderr, G_IO_IN, _log_write_cb, proc);
+ g_get_current_time(&pinfo->started_time);
+ pinfo->id = g_child_watch_add(pid, _watch_im_status_cb, proc);
+
+@@ -521,13 +521,13 @@ imsettings_proc_get_property(GObject *object,
+ static void
+ imsettings_proc_info_finalize(IMSettingsProcInfo *pinfo)
+ {
+- if (pinfo->stdout) {
+- g_io_channel_unref(pinfo->stdout);
+- pinfo->stdout = NULL;
++ if (pinfo->_stdout) {
++ g_io_channel_unref(pinfo->_stdout);
++ pinfo->_stdout = NULL;
+ }
+- if (pinfo->stderr) {
+- g_io_channel_unref(pinfo->stderr);
+- pinfo->stderr = NULL;
++ if (pinfo->_stderr) {
++ g_io_channel_unref(pinfo->_stderr);
++ pinfo->_stderr = NULL;
+ }
+ if (pinfo->oid > 0) {
+ g_source_remove(pinfo->oid);
+--
+2.13.2
+
diff --git a/meta-xfce/recipes-extended/imsettings/imsettings_1.7.2.bb b/meta-xfce/recipes-extended/imsettings/imsettings_1.7.2.bb
index 4b2ca4947c..7a4ce05bff 100644
--- a/meta-xfce/recipes-extended/imsettings/imsettings_1.7.2.bb
+++ b/meta-xfce/recipes-extended/imsettings/imsettings_1.7.2.bb
@@ -11,7 +11,9 @@ inherit autotools gtk-doc gobject-introspection
SRC_URI = "https://bitbucket.org/tagoh/imsettings/downloads/${BPN}-${PV}.tar.bz2 \
file://gtk-is-required-by-notify.patch \
- file://multi-line-ACLOCAL_AMFLAGS-isnot-supported-by-autoreconf.patch"
+ file://multi-line-ACLOCAL_AMFLAGS-isnot-supported-by-autoreconf.patch \
+ file://0001-Rename-use-of-stdout-and-stderr.patch \
+ "
SRC_URI[md5sum] = "8153b0583a9f47d8a62af1f92fb9d3bf"
SRC_URI[sha256sum] = "41addf0458f760212b6b6100835066e16deb3a8a50eb005a0fc17fbac0a2ae66"