aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmx.de>2011-10-30 11:47:19 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-31 11:25:55 +0100
commit7faafa8b3c0b1de2a2d8b6fe49076473f25589c0 (patch)
treeb0e025e76ae34583f91a1b11daa881e4a9cef03e /meta-xfce
parenteabd5d988e56a50edd591f5b2e598cc57df9dda6 (diff)
downloadmeta-openembedded-contrib-7faafa8b3c0b1de2a2d8b6fe49076473f25589c0.tar.gz
xfce-app.bbclass: just set SRC_URI commmon to most xfce-apps
* build tested with source download for xfce4-notifyd and xfce4-screenshooter * run tested on overo Signed-off-by: Andreas Müller <schnitzeltony@gmx.de> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/classes/xfce-app.bbclass4
-rw-r--r--meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.2.bb5
-rw-r--r--meta-xfce/recipes-apps/xfce4-screenshooter/xfce4-screenshooter_1.8.0.bb7
3 files changed, 6 insertions, 10 deletions
diff --git a/meta-xfce/classes/xfce-app.bbclass b/meta-xfce/classes/xfce-app.bbclass
new file mode 100644
index 0000000000..c60ad3d67a
--- /dev/null
+++ b/meta-xfce/classes/xfce-app.bbclass
@@ -0,0 +1,4 @@
+inherit xfce
+
+SRC_URI = "http://archive.xfce.org/src/apps/${BPN}/${@'${PV}'[0:3]}/${BPN}-${PV}.tar.bz2"
+
diff --git a/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.2.bb b/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.2.bb
index 4fea1deadb..0ee6da3ab9 100644
--- a/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.2.bb
+++ b/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.2.bb
@@ -6,10 +6,7 @@ DEPENDS = "libxfce4util libxfce4ui xfconf gtk+ dbus dbus-glib"
PR = "r0"
-inherit xfce
-
-# SRC_URI must follow inherited one
-SRC_URI = "http://archive.xfce.org/src/apps/${PN}/${@'${PV}'[0:3]}/${PN}-${PV}.tar.bz2"
+inherit xfce-app
FILES_${PN} += " \
${libdir}/xfce4/notifyd \
diff --git a/meta-xfce/recipes-apps/xfce4-screenshooter/xfce4-screenshooter_1.8.0.bb b/meta-xfce/recipes-apps/xfce4-screenshooter/xfce4-screenshooter_1.8.0.bb
index ef409c1238..2362b8abf8 100644
--- a/meta-xfce/recipes-apps/xfce4-screenshooter/xfce4-screenshooter_1.8.0.bb
+++ b/meta-xfce/recipes-apps/xfce4-screenshooter/xfce4-screenshooter_1.8.0.bb
@@ -7,12 +7,7 @@ DEPENDS = "xfce4-panel libxfce4util libxfce4ui gdk-pixbuf gtk+ glib-2.0 libsoup-
PR = "r0"
-inherit xfce
-
-# SRC_URI must follow inherited one
-# decoded to e.g. http://archive.xfce.org/src/apps/xfce4-screenshooter/1.8/xfce4-screenshooter-1.8.0.tar.bz2
-SRC_URI = "http://archive.xfce.org/src/apps/${PN}/${@'${PV}'[0:3]}/${PN}-${PV}.tar.bz2 \
-"
+inherit xfce-app
FILES_${PN} += "${datadir}/xfce4/panel-plugins/*"
FILES_${PN}-dbg += "${libexecdir}/xfce4/panel-plugins/.debug"