aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2019-08-09 01:31:21 -0400
committerKhem Raj <raj.khem@gmail.com>2019-08-09 09:19:03 -0700
commitb2c96a97f2e326e181d2c801f8ba498bd8dadd56 (patch)
tree6f259e18796db5c0023a0252ad1baafbf9464e76 /meta-xfce
parentcb036c84043af376f6b1e0a902e281ae25f908b7 (diff)
downloadmeta-openembedded-contrib-b2c96a97f2e326e181d2c801f8ba498bd8dadd56.tar.gz
xfce4-datetime-setter: add recipe
Because xfce4-settings turn back to its official upstream, it missing function to set date and time. Add it from Andreas's repo on github. xfce4-datetime-setter calls functions from dbus service org.freedesktop.timedate1 to set date and time. And the dbus service is provided by systemd. So check distro feature 'systemd' that xfce4-datetime-setter is imcompatible with sysvinit. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-apps/xfce4-datetime-setter/xfce4-datetime-setter_3.32.2.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-xfce/recipes-apps/xfce4-datetime-setter/xfce4-datetime-setter_3.32.2.bb b/meta-xfce/recipes-apps/xfce4-datetime-setter/xfce4-datetime-setter_3.32.2.bb
new file mode 100644
index 0000000000..d643585370
--- /dev/null
+++ b/meta-xfce/recipes-apps/xfce4-datetime-setter/xfce4-datetime-setter_3.32.2.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "A fork of (early) gnome-control-center datetime panel for XFCE. \
+It is based upon GTK3 and embedds into recent xfce4-settings."
+HOMEPAGE = "https://github.com/schnitzeltony/xfce4-datetime-setter"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=75859989545e37968a99b631ef42722e"
+
+DEPENDS = "glib-2.0-native libxfce4ui"
+
+SRC_URI = "git://github.com/schnitzeltony/xfce4-datetime-setter.git;protocol=https"
+SRCREV = "5c7a73a3824b03b91719e05e2604b97c7a72d50f"
+
+S = "${WORKDIR}/git"
+
+inherit gettext meson distro_features_check
+REQUIRED_DISTRO_FEATURES = "systemd"
+
+FILES_${PN} += "${datadir}/icons/hicolor"
+
+RDEPENDS_${PN} = "tzdata"