aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-08-30 12:33:58 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-08 16:18:35 +0200
commita0b93d8c18ccc9ac30e55431bbdc8e860bb428b4 (patch)
tree3a9850dae5da2269e005aac25b3a8d40bb15c3a9 /meta-xfce
parent387a933db677f2fa702c464e073d84bc7bf0b649 (diff)
downloadmeta-openembedded-contrib-a0b93d8c18ccc9ac30e55431bbdc8e860bb428b4.tar.gz
xfce4-notifyd: fix build for libnotify 0.7.x
the patch included during last commit only made latest xfce4-notifyd work with old version of libnotify. I expected it to work also for libnotify 0.7.x but that failed so remove the patch. Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-apps/xfce4-notifyd/files/0001-Restore-libnotify-version-7.0.0-compatibility.patch152
-rw-r--r--meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.4.bb1
2 files changed, 0 insertions, 153 deletions
diff --git a/meta-xfce/recipes-apps/xfce4-notifyd/files/0001-Restore-libnotify-version-7.0.0-compatibility.patch b/meta-xfce/recipes-apps/xfce4-notifyd/files/0001-Restore-libnotify-version-7.0.0-compatibility.patch
deleted file mode 100644
index 9e61a0ecfd..0000000000
--- a/meta-xfce/recipes-apps/xfce4-notifyd/files/0001-Restore-libnotify-version-7.0.0-compatibility.patch
+++ /dev/null
@@ -1,152 +0,0 @@
-From ebfbe9358068716ed7f39e253bce4d13e696bc9b Mon Sep 17 00:00:00 2001
-From: Ivailo Monev <xakepa10@gmail.com>
-Date: Wed, 11 Dec 2013 13:18:13 +0000
-Subject: [PATCH 1/1] Restore libnotify version < 7.0.0 compatibility
-
-Upstream-Status: Pending [1]
-
-[1] https://mail.xfce.org/pipermail/xfce/2013-December/032733.html
-
-Signed-off-by: Ivailo Monev <xakepa10@gmail.com>
----
- Makefile.am | 4 +++-
- configure.ac | 2 +-
- tests/test-actions.c | 7 ++++++-
- tests/test-positioning.c | 7 ++++++-
- tests/test-text.c | 21 ++++++++++++++++++---
- xfce4-notifyd-config/main.c | 7 ++++++-
- 6 files changed, 40 insertions(+), 8 deletions(-)
-
-diff --git a/Makefile.am b/Makefile.am
-index df81bea..034d6c1 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -271,9 +271,11 @@ noinst_PROGRAMS = \
-
- tests_cflags = \
- -I$(top_srcdir) \
-- $(LIBNOTIFY_CFLAGS)
-+ $(LIBNOTIFY_CFLAGS) \
-+ $(common_cflags)
-
- tests_ldadd = \
-+ $(common_ldadd) \
- $(LIBNOTIFY_LIBS)
-
- tests_test_actions_SOURCES = tests/test-actions.c
-diff --git a/configure.ac b/configure.ac
-index cf5258f..9d2e8a7 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -67,7 +67,7 @@ XDT_CHECK_PACKAGE([XFCONF], [libxfconf-0], [0.1.0svn-r26876])
- XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.14.0])
- XDT_CHECK_PACKAGE([DBUS], [dbus-1], [1.0.0])
- XDT_CHECK_PACKAGE([DBUS_GLIB], [dbus-glib-1], [0.72])
--XDT_CHECK_PACKAGE([LIBNOTIFY], [libnotify], [0.7.0])
-+XDT_CHECK_PACKAGE([LIBNOTIFY], [libnotify], [0.5.0])
-
- AC_PATH_PROG([DBUS_BINDING_TOOL], [dbus-binding-tool])
- AS_IF([test -z "$DBUS_BINDING_TOOL"],
-diff --git a/tests/test-actions.c b/tests/test-actions.c
-index a7f6494..4cdf882 100644
---- a/tests/test-actions.c
-+++ b/tests/test-actions.c
-@@ -106,7 +106,12 @@ int main (int argc, char **argv)
-
- notification = notify_notification_new ("Action!",
- "Click my shiny actions",
-- NULL);
-+ NULL
-+#if NOTIFY_CHECK_VERSION > (0, 6, 9)
-+ );
-+#else
-+ ,NULL);
-+#endif
-
- notify_notification_add_action (notification,
- "action1",
-diff --git a/tests/test-positioning.c b/tests/test-positioning.c
-index 4478a92..2a90c6e 100644
---- a/tests/test-positioning.c
-+++ b/tests/test-positioning.c
-@@ -60,7 +60,12 @@ int main (int argc, char **argv)
-
- notification = notify_notification_new (summary,
- body,
-- NULL);
-+ NULL
-+#if NOTIFY_CHECK_VERSION > (0, 6, 9)
-+ );
-+#else
-+ ,NULL);
-+#endif
-
- if (!notify_notification_show (notification, NULL))
- {
-diff --git a/tests/test-text.c b/tests/test-text.c
-index 7500cb2..ac95931 100644
---- a/tests/test-text.c
-+++ b/tests/test-text.c
-@@ -40,7 +40,12 @@ int main (int argc, char **argv)
-
- notification = notify_notification_new ("Test text support",
- "Does it work?",
-- NULL);
-+ NULL
-+#if NOTIFY_CHECK_VERSION > (0, 6, 9)
-+ );
-+#else
-+ ,NULL);
-+#endif
-
- if (!notify_notification_show (notification, NULL))
- {
-@@ -56,7 +61,12 @@ int main (int argc, char **argv)
-
- notification = notify_notification_new ("Summary only support",
- NULL,
-- NULL);
-+ NULL
-+#if NOTIFY_CHECK_VERSION > (0, 6, 9)
-+ );
-+#else
-+ ,NULL);
-+#endif
-
- if (!notify_notification_show (notification, NULL))
- {
-@@ -75,7 +85,12 @@ int main (int argc, char **argv)
- "<b>Bold</b>\n"
- "<u>Underlined</u>\n"
- "<a href=\"http://www.xfce.org\">Xfce Web site</a>",
-- NULL);
-+ NULL
-+#if NOTIFY_CHECK_VERSION > (0, 6, 9)
-+ );
-+#else
-+ ,NULL);
-+#endif
-
- if (!notify_notification_show (notification, NULL))
- {
-diff --git a/xfce4-notifyd-config/main.c b/xfce4-notifyd-config/main.c
-index 5977749..eff4994 100644
---- a/xfce4-notifyd-config/main.c
-+++ b/xfce4-notifyd-config/main.c
-@@ -56,7 +56,12 @@ xfce_notifyd_config_show_notification_preview(GtkWindow *parent_window)
- notification =
- notify_notification_new(_("Notification Preview"),
- _("This is how notifications will look like"),
-- "xfce4-notifyd");
-+ "xfce4-notifyd"
-+#if NOTIFY_CHECK_VERSION > (0, 6, 9)
-+ );
-+#else
-+ ,NULL);
-+#endif
-
- notify_notification_add_action(notification,
- "button",
---
-1.9.3
-
diff --git a/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.4.bb b/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.4.bb
index 9d0e19801e..5f874adcd9 100644
--- a/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.4.bb
+++ b/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.4.bb
@@ -8,7 +8,6 @@ inherit xfce-app
SRC_URI[md5sum] = "094be6f29206aac8299f27084e284e88"
SRC_URI[sha256sum] = "8c7ed62f9496816d1391281f77d1b32216f9bf6fd22fbe4f6f3f4e07a6bbced0"
-SRC_URI += "file://0001-Restore-libnotify-version-7.0.0-compatibility.patch"
do_compile_prepend() {
mkdir -p xfce4-notifyd