aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-22 15:34:51 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-05 19:26:12 +0200
commitc142219d33d80fe9525dfda10650fb6f88270b29 (patch)
treee18272d11a555f3e55e0b208a4c8b64ef32af32f /meta-xfce
parentb1b626c1650309bb5e1c9ed67681d7f0dc268d46 (diff)
downloadmeta-openembedded-contrib-c142219d33d80fe9525dfda10650fb6f88270b29.tar.gz
xfce4-timer-plugin: Fix build when security flags are enabled with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-panel-plugins/timer/xfce4-timer-plugin/0001-Specify-string-format-explicitly.patch32
-rw-r--r--meta-xfce/recipes-panel-plugins/timer/xfce4-timer-plugin_1.6.0.bb2
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-xfce/recipes-panel-plugins/timer/xfce4-timer-plugin/0001-Specify-string-format-explicitly.patch b/meta-xfce/recipes-panel-plugins/timer/xfce4-timer-plugin/0001-Specify-string-format-explicitly.patch
new file mode 100644
index 0000000000..3f0bb05af4
--- /dev/null
+++ b/meta-xfce/recipes-panel-plugins/timer/xfce4-timer-plugin/0001-Specify-string-format-explicitly.patch
@@ -0,0 +1,32 @@
+From 6b786e1c161026ab5486ac218891a85db65bf3ba Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 22 Mar 2017 15:28:24 -0700
+Subject: [PATCH] Specify string format explicitly
+
+Avoids below errors when compiling with -Wformat-security
+
+error: format string is not a string literal (potentially insecure)
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Pending
+
+ src/xfcetimer.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/xfcetimer.c b/src/xfcetimer.c
+index 601772f..4b89682 100644
+--- a/src/xfcetimer.c
++++ b/src/xfcetimer.c
+@@ -190,7 +190,7 @@ static gboolean update_function (gpointer data){
+
+ dialog = gtk_message_dialog_new (NULL, GTK_DIALOG_MODAL,
+ GTK_MESSAGE_WARNING,
+- GTK_BUTTONS_NONE, dialog_message);
++ GTK_BUTTONS_NONE, "%s", dialog_message);
+
+ gtk_window_set_title ((GtkWindow *) dialog, dialog_title);
+
+--
+2.12.0
+
diff --git a/meta-xfce/recipes-panel-plugins/timer/xfce4-timer-plugin_1.6.0.bb b/meta-xfce/recipes-panel-plugins/timer/xfce4-timer-plugin_1.6.0.bb
index d61235fe0e..9615192858 100644
--- a/meta-xfce/recipes-panel-plugins/timer/xfce4-timer-plugin_1.6.0.bb
+++ b/meta-xfce/recipes-panel-plugins/timer/xfce4-timer-plugin_1.6.0.bb
@@ -6,5 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ae39271267fd63eb7619432ff24e7ff1"
inherit xfce-panel-plugin
+SRC_URI += "file://0001-Specify-string-format-explicitly.patch"
+
SRC_URI[md5sum] = "3be2a4ccfb2af20441b1d25c2cea5f28"
SRC_URI[sha256sum] = "39d7d21f099bc4219f6a6156142f0bbb8374986ee1970a9c0c8dc138b87f867c"