aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2017-12-01 12:08:07 +0100
committerArmin Kuster <akuster808@gmail.com>2017-12-11 07:58:56 -0800
commitcbc64e6f4ec571009a5061f13ae01443917c435e (patch)
tree5f2708847d74fcf30543c7cd53ffb8b085e52a5e /meta-xfce
parentda778f933ccf34d01dfe8ca273c2191acfb36ef3 (diff)
downloadmeta-openembedded-contrib-cbc64e6f4ec571009a5061f13ae01443917c435e.tar.gz
tumbler: ensure thumbnails work properly
After some builds link tumbler-cache-plugin.so is not prperly created causing: | Failed to load the cache plugin "tumbler-cache-plugin.so": /usr/lib/tumbler-1/plugins/cache/tumbler-cache-plugin.so: cannot open shared object file: No such file or directory Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-xfce/tumbler/tumbler_0.2.0.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/tumbler/tumbler_0.2.0.bb b/meta-xfce/recipes-xfce/tumbler/tumbler_0.2.0.bb
index 49222063c2..7e0c555a4e 100644
--- a/meta-xfce/recipes-xfce/tumbler/tumbler_0.2.0.bb
+++ b/meta-xfce/recipes-xfce/tumbler/tumbler_0.2.0.bb
@@ -15,6 +15,12 @@ INSANE_SKIP_${PN} = "dev-so"
PACKAGECONFIG ??= ""
PACKAGECONFIG[gstreamer-thumbnailer] = "--enable-gstreamer-thumbnailer,--disable-gstreamer-thumbnailer,gstreamer1.0 gstreamer1.0-plugins-base"
+do_install_append() {
+ # Makefile seems to race on creation of symlink. So ensure creation here
+ # until fixed properly
+ ln -sf tumbler-xdg-cache.so ${D}${libdir}/tumbler-1/plugins/cache/tumbler-cache-plugin.so
+}
+
FILES_${PN} += "${datadir}/dbus-1/services \
${libdir}/tumbler-1/tumblerd \
${libdir}/tumbler-1/plugins/*.so \