aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-10-28 22:59:50 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-23 15:23:58 +0100
commit5a752d719eb35dcbdf4b58bd70ec904befbe0c59 (patch)
treea8e3990c46eab69919161ab8c3cf810272699701 /meta-xfce/recipes-xfce
parentedf147b90f446e10e08b9397b96db5d67b710b33 (diff)
downloadmeta-openembedded-contrib-5a752d719eb35dcbdf4b58bd70ec904befbe0c59.tar.gz
exo: unbreak Thunar's detailed file view
see further details at [1] [1] https://bugzilla.xfce.org/show_bug.cgi?id=12916 Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-xfce')
-rw-r--r--meta-xfce/recipes-xfce/exo/exo/0001-Probable-fix-for-Thunar-detailed-view-Xfce-12916.patch36
-rw-r--r--meta-xfce/recipes-xfce/exo/exo_0.11.1.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/exo/exo/0001-Probable-fix-for-Thunar-detailed-view-Xfce-12916.patch b/meta-xfce/recipes-xfce/exo/exo/0001-Probable-fix-for-Thunar-detailed-view-Xfce-12916.patch
new file mode 100644
index 0000000000..16f12feaf3
--- /dev/null
+++ b/meta-xfce/recipes-xfce/exo/exo/0001-Probable-fix-for-Thunar-detailed-view-Xfce-12916.patch
@@ -0,0 +1,36 @@
+From fea2619e6d07ac72b2eff6f408bb3daa2dbdf671 Mon Sep 17 00:00:00 2001
+From: Sean Davis <smd.seandavis@gmail.com>
+Date: Thu, 27 Oct 2016 20:31:36 -0400
+Subject: [PATCH] Probable fix for Thunar detailed view (Xfce #12916)
+
+Upstream-Status: Pending [1-2]
+
+[1] https://git.xfce.org/xfce/exo/commit/?id=fea2619e6d07ac72b2eff6f408bb3daa2dbdf671
+[2] https://bugzilla.xfce.org/show_bug.cgi?id=12916
+
+---
+ exo/exo-tree-view.c | 6 +-----
+ 1 file changed, 1 insertion(+), 5 deletions(-)
+
+diff --git a/exo/exo-tree-view.c b/exo/exo-tree-view.c
+index 8c8564f..2d0fc04 100644
+--- a/exo/exo-tree-view.c
++++ b/exo/exo-tree-view.c
+@@ -385,13 +385,9 @@ exo_tree_view_button_press_event (GtkWidget *widget,
+ }
+ }
+
+- /* see bug http://bugzilla.xfce.org/show_bug.cgi?id=6230 for more information */
+ if (G_LIKELY (gtk_tree_selection_get_select_function (selection) == (GtkTreeSelectionFunc) exo_noop_false))
+ {
+- /* just reset the select function (previously set to exo_noop_false),
+- * there's no clean way to do this, so what the heck.
+- */
+- gtk_tree_selection_set_select_function (selection, NULL, NULL, NULL);
++ gtk_tree_selection_set_select_function (selection, (GtkTreeSelectionFunc) exo_noop_true, NULL, NULL);
+ }
+
+ /* release the path (if any) */
+--
+2.5.5
+
diff --git a/meta-xfce/recipes-xfce/exo/exo_0.11.1.bb b/meta-xfce/recipes-xfce/exo/exo_0.11.1.bb
index 92155f213a..0b0353b32b 100644
--- a/meta-xfce/recipes-xfce/exo/exo_0.11.1.bb
+++ b/meta-xfce/recipes-xfce/exo/exo_0.11.1.bb
@@ -11,6 +11,7 @@ inherit xfce pythonnative perlnative gtk-doc
SRC_URI += " \
file://exo-no-tests-0.8.patch \
file://configure.patch \
+ file://0001-Probable-fix-for-Thunar-detailed-view-Xfce-12916.patch \
"
SRC_URI_append_class-native = " \