aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.14.0.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2019-08-13 05:21:15 -0400
committerKhem Raj <raj.khem@gmail.com>2019-08-14 16:03:44 -0700
commit8abba9a7e605e83ab4514e201fc3c6aa07fc4469 (patch)
tree1b8c156e7bf7bb239147a1060dbf8e4e6fb80f4b /meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.14.0.bb
parent81290f06be98b674757600d246f0bef3444d119a (diff)
downloadmeta-openembedded-contrib-8abba9a7e605e83ab4514e201fc3c6aa07fc4469.tar.gz
xfce4-session: 4.13.3 -> 4.14.0
Update xfce4-session from 4.13.3 to 4.14.0. * remove dbus from DEPENDS that xfce4-session ports to gdbus. gdbus is provided by glib-2.0 which in the dependency chain alreay. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.14.0.bb')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.14.0.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.14.0.bb b/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.14.0.bb
new file mode 100644
index 0000000000..6b4cafd009
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.14.0.bb
@@ -0,0 +1,40 @@
+SUMMARY = "xfce4-session is a session manager for Xfce 4 Desktop Environment"
+SECTION = "x11"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=9ac2e7cff1ddaf48b6eab6028f23ef88"
+
+DEPENDS = "libwnck3 libsm libxfce4ui virtual/libx11"
+
+inherit xfce update-alternatives distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "x11"
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)}"
+PACKAGECONFIG[polkit] = "--enable-polkit, --disable-polkit, polkit"
+
+SRC_URI += " \
+ file://0001-configure.in-hard-code-path-to-iceauth.patch \
+"
+SRC_URI[md5sum] = "635361f99a01b2d26c430a520b6d1314"
+SRC_URI[sha256sum] = "14fb6db74eb69eb400673856ba307a0e57f577cf77c3561a5910151e3d52043f"
+
+ALTERNATIVE_${PN} = "x-session-manager"
+ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/xfce4-session"
+ALTERNATIVE_PRIORITY_${PN} = "100"
+
+FILES_${PN} += " \
+ ${libdir}/xfce4/*/*/*.so \
+ ${libdir}/xfce4/session/*-*-* \
+ ${datadir}/xsessions \
+ ${datadir}/themes/Default/balou/* \
+ ${datadir}/polkit-1 \
+"
+
+RDEPENDS_${PN} = " \
+ dbus-x11 \
+ iceauth \
+ netbase \
+ upower \
+ xinit \
+ xrdb \
+"