aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.1.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-05-13 17:13:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-19 09:37:34 +0200
commit3d381d8e1f851cff64524bef953fb93d35879db3 (patch)
tree120a0ab07c4842c9d63327e49996520659128277 /meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.1.bb
parent35e9de7c662ee5292a3b4cf424ed6db2596a1bec (diff)
downloadmeta-openembedded-contrib-3d381d8e1f851cff64524bef953fb93d35879db3.tar.gz
xfce4-session: update to 4.10.1
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.1.bb')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.1.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.1.bb b/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.1.bb
new file mode 100644
index 0000000000..f7f4ba0c61
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.1.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "xfce4-session is a session manager for Xfce 4 Desktop Environment"
+SECTION = "x11"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=9ac2e7cff1ddaf48b6eab6028f23ef88"
+DEPENDS = "virtual/libx11 libsm libxfce4util libxfce4ui gtk+ libwnck dbus dbus-glib xfconf"
+RDEPENDS_${PN} = "netbase xinit dbus-x11 iceauth upower"
+
+inherit xfce update-alternatives
+
+SRC_URI[md5sum] = "1757657c1d590aa6274b7b7cbba33352"
+SRC_URI[sha256sum] = "0154fabdc398798c3445374ccc52a2f5bcb2d867fc94bc54114395b24f9cfc83"
+SRC_URI += " \
+ file://0001-configure.in-hard-code-path-to-iceauth.patch \
+"
+
+ALTERNATIVE_${PN} = "x-session-manager"
+ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/xfce4-session"
+
+# protect from frightening message that xfce might not work correctly
+pkg_postinst_${PN} () {
+ echo 127.0.0.1 ${MACHINE} >> /etc/hosts
+}
+
+PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES','systemd','systemd','consolekit',d)}"
+PACKAGECONFIG[systemd] = "--enable-systemd, --disable-systemd, polkit, systemd"
+PACKAGECONFIG[consolekit] = ",,,consolekit"
+
+FILES_${PN} += "${libdir}/xfce4/*/*/*.so \
+ ${libdir}/xfce4/session/*-*-* \
+ ${datadir}/xsessions \
+ ${datadir}/themes/Default/balou/*"
+
+FILES_${PN}-dbg += "${libdir}/xfce4/*/*/.debug"
+
+FILES_${PN}-staticdev += "${libdir}/xfce4/*/*/*.*a"