aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/tumbler/tumbler_0.3.1.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2020-11-19 15:41:34 +0800
committerKhem Raj <raj.khem@gmail.com>2020-11-19 07:36:26 -0800
commit4c8f3d93a1bb9313a7b87d79648839dfcef7e9d0 (patch)
treecafefba64343dc4ce3f726ea689ea929663910b9 /meta-xfce/recipes-xfce/tumbler/tumbler_0.3.1.bb
parentab53f2d9672220dd35c95f16ee0b082beef25fea (diff)
downloadmeta-openembedded-contrib-4c8f3d93a1bb9313a7b87d79648839dfcef7e9d0.tar.gz
tumbler: 0.2.9 -> 0.3.1
0.3.1 ===== - New plugin, libgepub thumbnailer plugin - Fix documentation URL - Add README.md and EXTRA_DIST - Add new icon needed for xfce4-about-dialog - Translation Updates: lt, oc, he, hi, hu, sk, tr, ug 0.3.0 ===== - Fix jpeg thumbnail orientation when fallback code is taken place (Bug #28). - Use AC_CONFIG_MACRO_DIRS instead of AC_CONFIG_MACRO_DIR - Fix GTimeVal deprecation - Drop support of GLib < 2.32 - Use guint32 for request handle and fix its further occurrences of 0 - Implement Excludes paths in tumbler.rc - Translation Updates: be, da, el, es, he, hu, hye, it, nl, pl, sq, zh_TW, zh_HK Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-xfce/tumbler/tumbler_0.3.1.bb')
-rw-r--r--meta-xfce/recipes-xfce/tumbler/tumbler_0.3.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/tumbler/tumbler_0.3.1.bb b/meta-xfce/recipes-xfce/tumbler/tumbler_0.3.1.bb
new file mode 100644
index 0000000000..c9f2ddc8b1
--- /dev/null
+++ b/meta-xfce/recipes-xfce/tumbler/tumbler_0.3.1.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Thumbnail service implementing the thumbnail management D-Bus specification"
+SECTION = "x11/libs"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+DEPENDS = "freetype gdk-pixbuf poppler curl xfce4-dev-tools-native libxml2 libgsf"
+
+inherit xfce gtk-doc
+
+SRC_URI[sha256sum] = "e4a30f3c0656b5b29fcd4a2450293f20f283a95b7fb0754a947c55427784c454"
+
+INSANE_SKIP_${PN} = "dev-so"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[gstreamer-thumbnailer] = "--enable-gstreamer-thumbnailer,--disable-gstreamer-thumbnailer,gstreamer1.0 gstreamer1.0-plugins-base"
+
+do_install_append() {
+ # Makefile seems to race on creation of symlink. So ensure creation here
+ # until fixed properly
+ ln -sf tumbler-xdg-cache.so ${D}${libdir}/tumbler-1/plugins/cache/tumbler-cache-plugin.so
+}
+
+FILES_${PN} += "${datadir}/dbus-1/services \
+ ${libdir}/tumbler-1/tumblerd \
+ ${libdir}/tumbler-1/plugins/*.so \
+ ${libdir}/tumbler-1/plugins/cache/*.so \
+"
+
+FILES_${PN}-dev += "${libdir}/tumbler-1/plugins/*.la \
+ ${libdir}/tumbler-1/plugins/cache/*.la \
+"