aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/tumbler/tumbler_0.2.7.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2019-08-13 05:21:10 -0400
committerKhem Raj <raj.khem@gmail.com>2019-08-14 16:03:43 -0700
commit348829309b0549f0f612854afc35c7aa26e5ea44 (patch)
treead2906764eeec25ac28e0b7e15fcabf59480400e /meta-xfce/recipes-xfce/tumbler/tumbler_0.2.7.bb
parent42355258db35c5c35e6193448a1beb4ec3fd715d (diff)
downloadmeta-openembedded-contrib-348829309b0549f0f612854afc35c7aa26e5ea44.tar.gz
tumbler: 0.2.0 -> 0.2.7
Update tumbler from 0.2.0 to 0.2.7 * remove patch which has been fixed in upstream * remove dbus-glib* from DEPENDS that tumbler ports gdbus. glib-2.0 provides gdbus and already in tumbler's dependency chains. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-xfce/tumbler/tumbler_0.2.7.bb')
-rw-r--r--meta-xfce/recipes-xfce/tumbler/tumbler_0.2.7.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/tumbler/tumbler_0.2.7.bb b/meta-xfce/recipes-xfce/tumbler/tumbler_0.2.7.bb
new file mode 100644
index 0000000000..434f8741af
--- /dev/null
+++ b/meta-xfce/recipes-xfce/tumbler/tumbler_0.2.7.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Thumbnail service implementing the thumbnail management D-Bus specification"
+SECTION = "x11/libs"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+DEPENDS = "freetype gdk-pixbuf poppler curl xfce4-dev-tools-native libxml2 libgsf"
+
+inherit xfce gtk-doc
+
+SRC_URI[md5sum] = "a59b2a545c9c128dbd2b960a7779dec0"
+SRC_URI[sha256sum] = "f704c35f16716cbee3c94883cee2a8d865e9cf2535d0e84f57e1c8cce00314e4"
+
+INSANE_SKIP_${PN} = "dev-so"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[gstreamer-thumbnailer] = "--enable-gstreamer-thumbnailer,--disable-gstreamer-thumbnailer,gstreamer1.0 gstreamer1.0-plugins-base"
+
+do_install_append() {
+ # Makefile seems to race on creation of symlink. So ensure creation here
+ # until fixed properly
+ ln -sf tumbler-xdg-cache.so ${D}${libdir}/tumbler-1/plugins/cache/tumbler-cache-plugin.so
+}
+
+FILES_${PN} += "${datadir}/dbus-1/services \
+ ${libdir}/tumbler-1/tumblerd \
+ ${libdir}/tumbler-1/plugins/*.so \
+ ${libdir}/tumbler-1/plugins/cache/*.so \
+"
+
+FILES_${PN}-dev += "${libdir}/tumbler-1/plugins/*.la \
+ ${libdir}/tumbler-1/plugins/cache/*.la \
+"