aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/exo/exo_0.12.9.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2019-11-21 00:38:05 +0100
committerKhem Raj <raj.khem@gmail.com>2019-11-21 17:52:26 -0800
commit8c9816bd3d312e1f059f562757cd25c0b79f11fe (patch)
treea70cdfa2ee47caaf1f40457d9236877c0d4cda79 /meta-xfce/recipes-xfce/exo/exo_0.12.9.bb
parent86d4131dfabdf4bca27d96de6f271565f1a3a5c6 (diff)
downloadmeta-openembedded-contrib-8c9816bd3d312e1f059f562757cd25c0b79f11fe.tar.gz
exo: upgrade 0.12.8 -> 0.12.9
Release notes for 0.12.9 ======================== Bug Fixes: - Explicitly depend on gio-unix-2.0 (Xfce #15825) - Fix alignment of multi-line filenames when text beside icons (Xfce - Fix cursor missing in search popup widget (Xfce #16068) - Fix desktop item creation on symbolic link directories - Fix excess clickable area of multiline filenames (Xfce #16075) - Fix issues with displaying icon view contents (Xfce #14737) - Fix prelight deactivation (Xfce #11806) - Hide search widget when doing a fullscreen resize (Xfce #15106) - Make user-created launchers executable by default Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Kai Kang <kai.kang@windriver.com>
Diffstat (limited to 'meta-xfce/recipes-xfce/exo/exo_0.12.9.bb')
-rw-r--r--meta-xfce/recipes-xfce/exo/exo_0.12.9.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/exo/exo_0.12.9.bb b/meta-xfce/recipes-xfce/exo/exo_0.12.9.bb
new file mode 100644
index 0000000000..8d59be13b5
--- /dev/null
+++ b/meta-xfce/recipes-xfce/exo/exo_0.12.9.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Application library for the Xfce desktop environment"
+SECTION = "x11"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+DEPENDS = "gtk+3 libxfce4ui virtual/libx11 liburi-perl-native cairo"
+DEPENDS_class-native = "glib-2.0-native xfce4-dev-tools-native intltool-native"
+
+inherit xfce pythonnative perlnative gtk-doc features_check
+
+REQUIRED_DISTRO_FEATURES = "x11"
+REQUIRED_DISTRO_FEATURES_class-native = ""
+
+# SRC_URI must follow inherited one
+SRC_URI += " \
+ file://exo-no-tests-0.8.patch \
+ file://configure.patch \
+"
+
+SRC_URI_append_class-native = " \
+ file://reduce-build-to-exo-csource-only.patch \
+"
+
+SRC_URI[md5sum] = "9730f9d270b4968a8bbebe73e6de934f"
+SRC_URI[sha256sum] = "9ba0bf0fd59aeb1cd32ae3863e7a78222655eb15eb675ba08f3b3fb933b6fbfe"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG_class-target ??= "gtk"
+PACKAGECONFIG[gtk] = "--enable-gtk2,--disable-gtk2,gtk+"
+
+PACKAGES =+ "exo-csource"
+
+# Note: python bindings did not work in oe-dev and are about to be moved to
+# pyxfce see http://comments.gmane.org/gmane.comp.desktop.xfce.devel.version4/19560
+FILES_${PN} += " \
+ ${datadir}/xfce4/ \
+ ${libdir}/xfce4/exo* \
+"
+
+FILES_exo-csource += "${bindir}/exo-csource"
+
+BBCLASSEXTEND = "native"