aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-art
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-05-19 17:49:29 +0200
committerAndreas Müller <schnitzeltony@googlemail.com>2012-09-18 15:54:01 +0200
commitab5135c573c176518bd34cc31b380f148a42a924 (patch)
tree2a28472cb2db849ae78bdf461e6e31b20c5b4a24 /meta-xfce/recipes-art
parent1f619ccf440278b5ed0838dd961f6f805a0dd9b6 (diff)
downloadmeta-openembedded-contrib-ab5135c573c176518bd34cc31b380f148a42a924.tar.gz
xfwm4-themes: initial add 4.10.0
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-xfce/recipes-art')
-rw-r--r--meta-xfce/recipes-art/xfwm4-themes/xfwm4-themes_4.10.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-xfce/recipes-art/xfwm4-themes/xfwm4-themes_4.10.0.bb b/meta-xfce/recipes-art/xfwm4-themes/xfwm4-themes_4.10.0.bb
new file mode 100644
index 0000000000..c018cb5285
--- /dev/null
+++ b/meta-xfce/recipes-art/xfwm4-themes/xfwm4-themes_4.10.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Additional (old) themes for Xfwm4"
+SECTION = "x11/wm"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+inherit xfce
+
+SRC_URI = "http://archive.xfce.org/src/art/${PN}/${@'${PV}'[0:4]}/${PN}-${PV}.tar.bz2"
+SRC_URI[md5sum] = "eaa58362053a3549c8be0b32efd3c54f"
+SRC_URI[sha256sum] = "3214d5f00e9703b5e8c9e7c3287d606dedec7285ceb4d5db332e93ada66fd575"
+
+# using xfwm4-theme as in xfwm4 might cause warnings of packages supplied by
+# multiple providers. So we use xfwm4-old-theme here.
+python populate_packages_prepend () {
+ themedir = bb.data.expand('${datadir}/themes', d)
+ do_split_packages(d, themedir, '^(.*)', 'xfwm4-old-theme-%s', 'XFWM4 theme %s', allow_dirs=True)
+}
+
+PACKAGES_DYNAMIC += "xfwm4-old-theme-*"