aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-art
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-12-23 13:02:32 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2012-12-27 16:14:21 +0100
commit540e9811f06cd6edf42b31f574d6ab44a8924005 (patch)
tree241a6b932062868bd648ad5fad8c1d6942c0ff10 /meta-xfce/recipes-art
parent6f65d9124f0d01b3d0cf08a0a6e18343b197f05a (diff)
downloadmeta-openembedded-contrib-540e9811f06cd6edf42b31f574d6ab44a8924005.tar.gz
openzone: Initial add 1.2.3
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-art')
-rw-r--r--meta-xfce/recipes-art/cursor-themes/openzone_1.2.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-xfce/recipes-art/cursor-themes/openzone_1.2.3.bb b/meta-xfce/recipes-art/cursor-themes/openzone_1.2.3.bb
new file mode 100644
index 0000000000..2e19d89800
--- /dev/null
+++ b/meta-xfce/recipes-art/cursor-themes/openzone_1.2.3.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "X11 Mouse Theme"
+HOMEPAGE = "http://xfce-look.org/content/show.php/OpenZone?content=111343"
+SECTION = "x11/wm"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a2f562fb8fb1e138b810d69521c4bcd7"
+DEPENDS = "icon-slicer-native xcursorgen-native"
+
+inherit allarch
+
+SRC_URI = "http://xfce-look.org/CONTENT/content-files/111343-OpenZone-${PV}.tar.xz"
+SRC_URI[md5sum] = "4dae968cbd525072664ef7a4fc7c4154"
+SRC_URI[sha256sum] = "dc20f97a49e1ff1becf7853ef5f137ed30a4c27490540e755021d78d339efd92"
+
+S = "${WORKDIR}/OpenZone"
+
+do_install() {
+ install -d ${D}${datadir}/icons
+ for theme in `find -name '*.tar.xz'`; do
+ tar -Jxf ${theme} -C ${D}${datadir}/icons
+ done
+}
+
+python populate_packages_prepend () {
+ icondir = bb.data.expand('${datadir}/icons', d)
+ do_split_packages(d, icondir, '^(.*)', '%s', 'Open Zone cursors %s', allow_dirs=True)
+}
+
+PACKAGES_DYNAMIC += "^openzone-.*"
+ALLOW_EMPTY_${PN} = "1"