aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-apps/xfce4-panel-profiles/xfce4-panel-profiles_1.0.12.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2021-01-03 15:12:32 +0100
committerKhem Raj <raj.khem@gmail.com>2021-01-05 09:16:26 -0800
commitf2d18ca23fffa99b95c47e49c7b4a008922ac812 (patch)
tree2a4fc5c1d9061b7b345446c53c5a18290b4ea8e1 /meta-xfce/recipes-apps/xfce4-panel-profiles/xfce4-panel-profiles_1.0.12.bb
parent04bb5ad26e2c5f5681c1c0f430623a4717ad217b (diff)
downloadmeta-openembedded-contrib-f2d18ca23fffa99b95c47e49c7b4a008922ac812.tar.gz
xfce4-panel-profiles: upgrade 1.0.10 -> 1.0.12
Release notes for 1.0.12 ======================== New Features: - New build option `--docdir` for documentation install path - New build option `--mandir` for manpage install path General: - Manpage `xfce4-panel-profiles.1` is no longer gzipped (#5) Bugs Fixed: - Release install error: incorrect README filename (#24) Release notes for 1.0.11 ======================== * New Features - Add support for saving xfce4-whiskermenu's configuration file - Prefer CSD in XfceTitledDialog - Use XfceTitledDialog from libxfce4ui - Use Xfce's about dialog via libxfce4ui - Add new icons and use reverse DNS for icons and files - Open xfce4-panel on close button (bug #16505) * General - Add new README.md over old README - Try the new and old libxfce4ui gir file name - Add basic GitLab pipeline - Make tarball creation reproducible * Bugs Fixed - Update openSUSE profile and fix build - Removed check for if the menu is installed. This would probably get in the way. - Use current branch in 'make distcheck' - Use configured appname instead of argv[0] - Fix typos in comments. * Updated translations: Albanian, Armenian (Armenia), Belarusian, Chinese (China), Chinese (Hong Kong), Chinese (Taiwan), Czech, Eastern Armenian, Estonian, Hebrew, Hungarian, Indonesian, Interlingue, Persian (Iran), Portuguese, Slovak, Spanish, Turkish Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-apps/xfce4-panel-profiles/xfce4-panel-profiles_1.0.12.bb')
-rw-r--r--meta-xfce/recipes-apps/xfce4-panel-profiles/xfce4-panel-profiles_1.0.12.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-xfce/recipes-apps/xfce4-panel-profiles/xfce4-panel-profiles_1.0.12.bb b/meta-xfce/recipes-apps/xfce4-panel-profiles/xfce4-panel-profiles_1.0.12.bb
new file mode 100644
index 0000000000..1fcb7edc03
--- /dev/null
+++ b/meta-xfce/recipes-apps/xfce4-panel-profiles/xfce4-panel-profiles_1.0.12.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Backup, restore, import, and export panel layouts"
+SECTION = "x11/application"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+inherit python3native gettext gtk-icon-cache features_check
+
+REQUIRED_DISTRO_FEATURES = "x11"
+
+DEPENDS += "intltool-native"
+
+SRC_URI = "http://archive.xfce.org/src/apps/${BPN}/1.0/${BP}.tar.bz2 \
+ file://not-create-link-to-locale.patch \
+ "
+SRC_URI[sha256sum] = "246e459d2d2f3f524968440ed7fddb2a891567ebc05f10a800f7f5821b3452a7"
+
+do_configure() {
+ # special configure - no autotools...
+ ./configure --prefix=${prefix}
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+ sed -i 's:${PYTHON}:python3:g' ${D}${bindir}/xfce4-panel-profiles
+}
+
+FILES_${PN} += "${datadir}/metainfo"
+
+RDEPENDS_${PN} += "python3-pygobject python3-pexpect"