aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authordengke.du@windriver.com <dengke.du@windriver.com>2017-05-09 03:54:33 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-05-23 15:49:36 +0200
commit6cd249225ecdd0a4592afe1844541378acae6cea (patch)
treeb84c1f9ab13a33e160cff362dfa0f21d363887e7 /meta-webserver
parent12436ba5ff647d69c0eadab7f4e5de42cf19f9ca (diff)
downloadmeta-openembedded-contrib-6cd249225ecdd0a4592afe1844541378acae6cea.tar.gz
php: fix install error for libphp*.so
Changed in V4: Add the tag: meta-oe 1. Different version php have different libphp*.so, so we need to install its corresponding libphp*.so, for example: php-7.1.0 libphp7.so php-5.6.26 libphp5.so 2. Fix php-5.6.26 compiling errors: ld: TSRM/.libs/TSRM.o: undefined reference to symbol 'pthread_sigmask@@GLIBC_2.2.5' error adding symbols: DSO missing from command line 3. Create a configure script like 70_mod_php5, we name it 70_mod_php7, this file connect the php7 and the apache2, so they work together to let the LAMP works correctly. Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-php/xdebug/xdebug_2.5.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-webserver/recipes-php/xdebug/xdebug_2.5.1.bb b/meta-webserver/recipes-php/xdebug/xdebug_2.5.1.bb
index 077bdc8a89..77413784d2 100644
--- a/meta-webserver/recipes-php/xdebug/xdebug_2.5.1.bb
+++ b/meta-webserver/recipes-php/xdebug/xdebug_2.5.1.bb
@@ -29,5 +29,5 @@ do_install() {
oe_runmake install INSTALL_ROOT=${D}
}
-FILES_${PN} += "${libdir}/php5/extensions/*/*.so"
-FILES_${PN}-dbg += "${libdir}/php5/extensions/*/.debug"
+FILES_${PN} += "${libdir}/php*/extensions/*/*.so"
+FILES_${PN}-dbg += "${libdir}/php*/extensions/*/.debug"