aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorJan Vermaete <jan.vermaete@gmail.com>2021-12-23 19:51:32 +0100
committerKhem Raj <raj.khem@gmail.com>2021-12-23 23:05:27 -0800
commitd68d340d8c206863af11a684c15f36b63466e633 (patch)
tree56574f0aba9a07d77fd9fe062dae3e482a2ce09c /meta-webserver
parent2bf65c1d863bed9cea746747ef119cdd7d6d6e71 (diff)
downloadmeta-openembedded-contrib-d68d340d8c206863af11a684c15f36b63466e633.tar.gz
netdata: fix for commit 8554624cc7f84e6b63b2ea4b94ee5fd2821021ca
The previous commit was using a PACKAGECONFIG to enable or disable the sending of anonymous data to Google Analytics. This was giving QA issues. Now the variable 'NETDATA_ANONYMOUS' is used to enable or disable the opt-out. Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb b/meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb
index 6824dd7257..dbce1c432f 100644
--- a/meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb
+++ b/meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb
@@ -20,9 +20,8 @@ UPSTREAM_CHECK_URI = "https://github.com/netdata/netdata/releases"
S = "${WORKDIR}/${BPN}-v${PV}"
-PACKAGECONFIG ??= "\
- anonymous \
-"
+# Stop sending anonymous statistics to Google Analytics
+NETDATA_ANONYMOUS ??= "enabled"
inherit pkgconfig autotools-brokensep useradd systemd
@@ -62,8 +61,7 @@ do_install:append() {
sed -i -e 's,@@libdir,${libexecdir},g' ${D}${sysconfdir}/netdata/netdata.conf
sed -i -e 's,@@datadir,${datadir},g' ${D}${sysconfdir}/netdata/netdata.conf
- # Stop sending anonymous statistics to Google Analytics
- if ${@bb.utils.contains('PACKAGECONFIG', 'anonymous', 'true', 'false', d)}; then
+ if [ "${NETDATA_ANONYMOUS}" = "enabled" ]; then
touch ${D}${sysconfdir}/netdata/.opt-out-from-anonymous-statistics
fi