aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorJan Vermaete <jan.vermaete@gmail.com>2022-01-30 19:09:34 +0100
committerKhem Raj <raj.khem@gmail.com>2022-02-03 08:41:05 -0800
commit32dd133a6bb193985f5214ee35ab9903305e8742 (patch)
tree6e6fe48c459dd52325886130ccfd3005e69c95b3 /meta-webserver
parentd0454ed6e60f3c52f2cfe521d78012ccd155336a (diff)
downloadmeta-openembedded-contrib-32dd133a6bb193985f5214ee35ab9903305e8742.tar.gz
netdata: upgrade 1.32.1 -> 1.33.0
Added the packageconfig to compress the data with lz4. But disabled it by default. Patch added to have it working without compression enabled. Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-webadmin/netdata/netdata/0001-Stream-Compression-Bug-fix-12043-lz4.h-compilation-e.patch26
-rw-r--r--meta-webserver/recipes-webadmin/netdata/netdata_1.33.0.bb (renamed from meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb)12
2 files changed, 35 insertions, 3 deletions
diff --git a/meta-webserver/recipes-webadmin/netdata/netdata/0001-Stream-Compression-Bug-fix-12043-lz4.h-compilation-e.patch b/meta-webserver/recipes-webadmin/netdata/netdata/0001-Stream-Compression-Bug-fix-12043-lz4.h-compilation-e.patch
new file mode 100644
index 0000000000..c699f956d6
--- /dev/null
+++ b/meta-webserver/recipes-webadmin/netdata/netdata/0001-Stream-Compression-Bug-fix-12043-lz4.h-compilation-e.patch
@@ -0,0 +1,26 @@
+From 85e59be1c656b946a1fcd19404cb0df6095e7dfb Mon Sep 17 00:00:00 2001
+From: odynik <odynik.ee@gmail.com>
+Date: Fri, 28 Jan 2022 12:15:41 +0200
+Subject: [PATCH 1/4] [Stream Compression] - Bug fix #12043 - lz4.h compilation
+ error - compile from source (#12049)
+
+---
+ streaming/compression.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/streaming/compression.c b/streaming/compression.c
+index 917f05bd6..93810aaed 100644
+--- a/streaming/compression.c
++++ b/streaming/compression.c
+@@ -1,7 +1,7 @@
+ #include "rrdpush.h"
+-#include "lz4.h"
+
+ #ifdef ENABLE_COMPRESSION
++#include "lz4.h"
+
+ #define LZ4_MAX_MSG_SIZE 0x4000
+ #define LZ4_STREAM_BUFFER_SIZE (0x10000 + LZ4_MAX_MSG_SIZE)
+--
+2.25.1
+
diff --git a/meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb b/meta-webserver/recipes-webadmin/netdata/netdata_1.33.0.bb
index dbce1c432f..8b6432cec1 100644
--- a/meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb
+++ b/meta-webserver/recipes-webadmin/netdata/netdata_1.33.0.bb
@@ -5,10 +5,13 @@ DESCRIPTION = "Netdata is high-fidelity infrastructure monitoring and troublesho
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://LICENSE;md5=fc9b848046ef54b5eaee6071947abd24"
-DEPENDS += "libuv openssl util-linux zlib "
+DEPENDS += "libuv openssl util-linux zlib"
-SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BPN}-v${PV}.tar.gz"
-SRC_URI[sha256sum] = "ac406513e86ad24976a66146702aeac960e43908abc51d70e4a073905275d13e"
+SRC_URI = "\
+ https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BPN}-v${PV}.tar.gz \
+ file://0001-Stream-Compression-Bug-fix-12043-lz4.h-compilation-e.patch \
+"
+SRC_URI[sha256sum] = "d167d4b2d8529119fa4047ae40d22833dac9d360a6ed07c314ba313807c027eb"
# default netdata.conf for netdata configuration
SRC_URI += "file://netdata.conf"
@@ -40,6 +43,9 @@ SYSTEMD_AUTO_ENABLE:${PN} = "enable"
USERADD_PACKAGES = "${PN}"
USERADD_PARAM:${PN} = "--system --no-create-home --home-dir ${localstatedir}/run/netdata --user-group netdata"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[compression] = "--enable-compression, --disable-compression, lz4"
+
# ebpf doesn't compile (or detect) the cross compilation well
EXTRA_OECONF += "--disable-ebpf"