aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorJan Vermaete <jan.vermaete@gmail.com>2021-12-19 09:47:54 +0100
committerKhem Raj <raj.khem@gmail.com>2021-12-23 23:05:27 -0800
commit2bf65c1d863bed9cea746747ef119cdd7d6d6e71 (patch)
treeb5a433b3091b4ad2b3a48248ff071236d86d7a41 /meta-webserver
parent3b883ba6d5cbe23f6d9e7c2e7e4b2c8f8f4069ab (diff)
downloadmeta-openembedded-contrib-2bf65c1d863bed9cea746747ef119cdd7d6d6e71.tar.gz
netdata: do not send anonymous statistics by default.
Netdata is sending anonymous statics data to Google by default. Disabling this by default in the recipe by adding the .opt-out-from-anonymous-statistics file in the netdata config directory. @see: https://learn.netdata.cloud/docs/agent/anonymous-statistics#opt-out Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb b/meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb
index d479051c4c..6824dd7257 100644
--- a/meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb
+++ b/meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb
@@ -20,6 +20,10 @@ UPSTREAM_CHECK_URI = "https://github.com/netdata/netdata/releases"
S = "${WORKDIR}/${BPN}-v${PV}"
+PACKAGECONFIG ??= "\
+ anonymous \
+"
+
inherit pkgconfig autotools-brokensep useradd systemd
LIBS:toolchain-clang:x86 = "-latomic"
@@ -58,6 +62,11 @@ do_install:append() {
sed -i -e 's,@@libdir,${libexecdir},g' ${D}${sysconfdir}/netdata/netdata.conf
sed -i -e 's,@@datadir,${datadir},g' ${D}${sysconfdir}/netdata/netdata.conf
+ # Stop sending anonymous statistics to Google Analytics
+ if ${@bb.utils.contains('PACKAGECONFIG', 'anonymous', 'true', 'false', d)}; then
+ touch ${D}${sysconfdir}/netdata/.opt-out-from-anonymous-statistics
+ fi
+
install --group netdata --owner netdata --directory ${D}${localstatedir}/cache/netdata
install --group netdata --owner netdata --directory ${D}${localstatedir}/lib/netdata