aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorYangHaibo <b40869@freescale.com>2014-08-05 15:31:33 +0800
committerPaul Eggleton <paul.eggleton@linux.intel.com>2014-08-10 17:23:22 +0100
commit4d4ab8fd320b58323033c12cf705e7b3ce10d659 (patch)
treee3bc03e58b5ed6835928769019794baf4af61413 /meta-webserver
parenteb45d8b6c716c43f4acbc9f35a8c916eefbe72e5 (diff)
downloadmeta-openembedded-contrib-4d4ab8fd320b58323033c12cf705e7b3ce10d659.tar.gz
integrate fcgi-2.4.0 and add OML license file
Signed-off-by: YangHaibo <b40869@freescale.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-support/fcgi/Fix_EOF_not_declared_issue.patch17
-rw-r--r--meta-webserver/recipes-support/fcgi/add_foreign_to_AM_INIT_AUTOMAKE.patch18
-rw-r--r--meta-webserver/recipes-support/fcgi_2.4.0.bb15
3 files changed, 50 insertions, 0 deletions
diff --git a/meta-webserver/recipes-support/fcgi/Fix_EOF_not_declared_issue.patch b/meta-webserver/recipes-support/fcgi/Fix_EOF_not_declared_issue.patch
new file mode 100644
index 0000000000..51ddeaac22
--- /dev/null
+++ b/meta-webserver/recipes-support/fcgi/Fix_EOF_not_declared_issue.patch
@@ -0,0 +1,17 @@
+Upstream-Status: Pending
+
+Fix EOF not declared issue, following is the error log.
+fcgio.cpp:70:72: error: 'EOF' was not declared in this scope
+ if (FCGX_PutStr(pbase(), plen, this->fcgx) != plen) return EOF;
+
+Signed-off-by: Yang Haibo <b40869@freescale.com>
+--- fcgi-ori/libfcgi/fcgio.cpp 2014-07-28 18:01:00.000000000 +0800
++++ fcgi-2.4.0/libfcgi/fcgio.cpp 2014-07-28 18:01:22.000000000 +0800
+@@ -22,6 +22,7 @@
+ #define DLLAPI __declspec(dllexport)
+ #endif
+
++#include <stdio.h>
+ #include <limits.h>
+ #include "fcgio.h"
+
diff --git a/meta-webserver/recipes-support/fcgi/add_foreign_to_AM_INIT_AUTOMAKE.patch b/meta-webserver/recipes-support/fcgi/add_foreign_to_AM_INIT_AUTOMAKE.patch
new file mode 100644
index 0000000000..eca694adc9
--- /dev/null
+++ b/meta-webserver/recipes-support/fcgi/add_foreign_to_AM_INIT_AUTOMAKE.patch
@@ -0,0 +1,18 @@
+Upstream-Status: Pending
+
+use automake options "foreign" to set the strictness as appropriate
+
+Signed-off-by: Yang Haibo <b40869@freescale.com>
+--- fcgi-ori/configure.in 2014-08-05 14:58:35.000000000 +0800
++++ fcgi-2.4.0/configure.in 2014-08-05 14:59:08.000000000 +0800
+@@ -4,8 +4,8 @@
+ dnl generate the file "configure", which is run during the build
+ dnl to configure the system for the local environment.
+
+-AC_INIT
+-AM_INIT_AUTOMAKE(fcgi, 2.4.0)
++AC_INIT([fcgi], [2.4.0])
++AM_INIT_AUTOMAKE([foreign])
+
+ AM_CONFIG_HEADER(fcgi_config.h)
+
diff --git a/meta-webserver/recipes-support/fcgi_2.4.0.bb b/meta-webserver/recipes-support/fcgi_2.4.0.bb
new file mode 100644
index 0000000000..ed718aefd9
--- /dev/null
+++ b/meta-webserver/recipes-support/fcgi_2.4.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "FastCGI is a protocol for interfacing interactive programs with a web server."
+HOMEPAGE = "http://www.fastcgi.com"
+LICENSE = "OML"
+LIC_FILES_CHKSUM = "file://LICENSE.TERMS;md5=e3aacac3a647af6e7e31f181cda0a06a"
+
+SRC_URI = "http://fossies.org/linux/www/${BP}.tar.gz \
+ file://Fix_EOF_not_declared_issue.patch \
+ file://add_foreign_to_AM_INIT_AUTOMAKE.patch \
+"
+SRC_URI[md5sum] = "d15060a813b91383a9f3c66faf84867e"
+SRC_URI[sha256sum] = "66fc45c6b36a21bf2fbbb68e90f780cc21a9da1fffbae75e76d2b4402d3f05b9"
+
+inherit autotools
+
+PARALLEL_MAKE = ""