aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-22 20:48:51 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-28 10:38:38 +0200
commite5c807b77fbe753e28483ae7d58d8a5dec676ace (patch)
treec719d92c331ac8682c5f92ebccb93be3b104b41d /meta-webserver
parent21f10c11f39020f9502d741c774a12d1aeb39499 (diff)
downloadmeta-openembedded-contrib-e5c807b77fbe753e28483ae7d58d8a5dec676ace.tar.gz
meta-webserver: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb4
-rw-r--r--meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb4
-rw-r--r--meta-webserver/recipes-httpd/hiawatha/hiawatha_9.2.bb2
-rw-r--r--meta-webserver/recipes-httpd/monkey/monkey_1.5.6.bb2
-rw-r--r--meta-webserver/recipes-httpd/nginx/nginx.inc2
-rw-r--r--meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb2
6 files changed, 8 insertions, 8 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb
index df2503421b..81151d1a47 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb
@@ -57,7 +57,7 @@ EXTRA_OECONF = "--enable-ssl \
--enable-mpms-shared \
ac_cv_have_threadsafe_pollset=no"
-PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
+PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux"
PACKAGECONFIG[openldap] = "--enable-ldap --enable-authnz-ldap,--disable-ldap --disable-authnz-ldap,openldap"
@@ -86,7 +86,7 @@ do_install_append() {
# Set 'ServerName' to fix error messages when restart apache service
sed -i 's/^#ServerName www.example.com/ServerName localhost/' ${D}/${sysconfdir}/${BPN}/httpd.conf
- if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${sysconfdir}/tmpfiles.d/
install -m 0644 ${WORKDIR}/apache2-volatile.conf ${D}${sysconfdir}/tmpfiles.d/
fi
diff --git a/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb b/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb
index 451e97cb74..5287ea42c1 100644
--- a/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb
+++ b/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
PR = "r9"
-DEPENDS = "libpcre openssl mysql5 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
+DEPENDS = "libpcre openssl mysql5 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
SRC_URI = "http://www.cherokee-project.de/mirrors/cherokee/1.2/${PV}/cherokee-${PV}.tar.gz \
file://cherokee.init \
@@ -26,7 +26,7 @@ PACKAGECONFIG[geoip] = "--with-geoip,--without-geoip,geoip"
EXTRA_OECONF = "--disable-static \
--disable-nls \
- ${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)} \
--with-wwwroot=${localstatedir}/www/cherokee \
"
diff --git a/meta-webserver/recipes-httpd/hiawatha/hiawatha_9.2.bb b/meta-webserver/recipes-httpd/hiawatha/hiawatha_9.2.bb
index 31293e48f9..7062174790 100644
--- a/meta-webserver/recipes-httpd/hiawatha/hiawatha_9.2.bb
+++ b/meta-webserver/recipes-httpd/hiawatha/hiawatha_9.2.bb
@@ -48,7 +48,7 @@ do_install_append() {
# by default if php is installed
echo "Server = ${bindir}/php-cgi ; 2 ; 127.0.0.1:2005 ; nobody:nobody ; ${sysconfdir}/php/hiawatha-php5/php.ini" >> ${D}${sysconfdir}/hiawatha/php-fcgi.conf
- if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
install -d ${D}/${systemd_unitdir}/system
install -m 644 ${WORKDIR}/hiawatha.service ${D}/${systemd_unitdir}/system
fi
diff --git a/meta-webserver/recipes-httpd/monkey/monkey_1.5.6.bb b/meta-webserver/recipes-httpd/monkey/monkey_1.5.6.bb
index 22d88f8e92..be8ed37b97 100644
--- a/meta-webserver/recipes-httpd/monkey/monkey_1.5.6.bb
+++ b/meta-webserver/recipes-httpd/monkey/monkey_1.5.6.bb
@@ -58,7 +58,7 @@ do_install_append() {
mkdir -p ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/monkey.init ${D}${sysconfdir}/init.d/monkey
- if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
install -d ${D}${systemd_unitdir}/system
install -m 644 ${WORKDIR}/monkey.service ${D}/${systemd_unitdir}/system
fi
diff --git a/meta-webserver/recipes-httpd/nginx/nginx.inc b/meta-webserver/recipes-httpd/nginx/nginx.inc
index 2169b67c55..ebf926a201 100644
--- a/meta-webserver/recipes-httpd/nginx/nginx.inc
+++ b/meta-webserver/recipes-httpd/nginx/nginx.inc
@@ -66,7 +66,7 @@ do_configure () {
do_install () {
oe_runmake 'DESTDIR=${D}' install
rm -fr ${D}${localstatedir}/run ${D}/run
- if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${sysconfdir}/tmpfiles.d
echo "d /run/${BPN} - - - -" \
> ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
diff --git a/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb b/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb
index fe860ec9a9..562ecd0049 100644
--- a/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb
+++ b/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb
@@ -46,7 +46,7 @@ do_install() {
install -m 0644 ${WORKDIR}/nhttpd.conf ${D}${sysconfdir}
install -m 0755 ${WORKDIR}/nostromo ${D}${sysconfdir}/init.d
install -D -m 0644 ${WORKDIR}/volatiles ${D}${sysconfdir}/default/volatiles/nostromo
- if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -D -m 0644 ${WORKDIR}/tmpfiles.conf ${D}${sysconfdir}/tmpfiles.d/nostromo.conf
fi
install -m 0644 htdocs/index.html ${D}${localstatedir}/nostromo/htdocs/index.html