aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-php/xdebug/xdebug_2.2.5.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2014-05-01 15:17:29 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2014-05-13 12:03:39 +0100
commit6e9591cc23376bdf9779b337340f60adf6dd0ba1 (patch)
treec7db245271b1b560e8d2c88523184a400b6253dc /meta-webserver/recipes-php/xdebug/xdebug_2.2.5.bb
parent0065398fa5867f48c5764abb72a706a316c3ffc9 (diff)
downloadmeta-openembedded-contrib-6e9591cc23376bdf9779b337340f60adf6dd0ba1.tar.gz
xdebug: update to 2.2.5
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-webserver/recipes-php/xdebug/xdebug_2.2.5.bb')
-rw-r--r--meta-webserver/recipes-php/xdebug/xdebug_2.2.5.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-webserver/recipes-php/xdebug/xdebug_2.2.5.bb b/meta-webserver/recipes-php/xdebug/xdebug_2.2.5.bb
new file mode 100644
index 0000000000..ffff13565e
--- /dev/null
+++ b/meta-webserver/recipes-php/xdebug/xdebug_2.2.5.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Debugging and profiling extension for PHP"
+LICENSE = "Xdebug"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=34df3a274aa12b795417c65634c07f16"
+
+DEPENDS = "modphp"
+
+
+SRC_URI = "http://xdebug.org/files/xdebug-${PV}.tgz"
+
+SRC_URI[md5sum] = "7e571ce8eb6fa969fd8263969019849d"
+SRC_URI[sha256sum] = "adc6fe92dcff2368be94d20a5997aadb4d46d74551e2dd6602a704a35a195a6f"
+
+inherit autotools
+
+EXTRA_OECONF += "--enable-xdebug -with-php-config=${STAGING_BINDIR_CROSS}/php-config"
+
+do_configure() {
+ cd ${S}
+ ${STAGING_BINDIR_CROSS}/phpize
+ cd ${B}
+
+ # Running autoreconf as autotools_do_configure would do here
+ # breaks the libtool configuration resulting in a failure later
+ # in do_compile. It's possible this may be fixable, however the
+ # easiest course of action for the moment is to avoid doing that.
+ oe_runconf
+}
+
+do_install() {
+ oe_runmake install INSTALL_ROOT=${D}
+}
+
+FILES_${PN} += "${libdir}/php5/extensions/*/*.so"
+FILES_${PN}-dbg += "${libdir}/php5/extensions/*/.debug"
+