aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorSander van Grieken <sander@outrightsolutions.nl>2012-09-07 11:01:17 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-09-10 10:56:49 +0200
commit733280b4286264f478f5df68cbb99492509c8961 (patch)
treeed71a2d26e6d65ac8048bac4bdf3fbf10a91be43 /meta-systemd
parenta5c8e3172008fcff788de63160f994ee7ab91151 (diff)
downloadmeta-openembedded-contrib-733280b4286264f478f5df68cbb99492509c8961.tar.gz
dnsmasq: add systemd service scripts for dnsmasq
Signed-off-by: Sander van Grieken <sander@outrightsolutions.nl> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/meta-oe/recipes-connectivity/dnsmasq/dnsmasq/dnsmasq.service13
-rw-r--r--meta-systemd/meta-oe/recipes-connectivity/dnsmasq/dnsmasq_2.55.bbappend10
2 files changed, 23 insertions, 0 deletions
diff --git a/meta-systemd/meta-oe/recipes-connectivity/dnsmasq/dnsmasq/dnsmasq.service b/meta-systemd/meta-oe/recipes-connectivity/dnsmasq/dnsmasq/dnsmasq.service
new file mode 100644
index 0000000000..549e15e2b2
--- /dev/null
+++ b/meta-systemd/meta-oe/recipes-connectivity/dnsmasq/dnsmasq/dnsmasq.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=DNS forwarder and DHCP server
+After=network.target
+
+[Service]
+Type=forking
+PIDFile=/run/dnsmasq.pid
+ExecStart=/usr/bin/dnsmasq -x /run/dnsmasq.pid
+ExecReload=/bin/kill -HUP $(/bin/cat /run/dnsmasq.pid)
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/meta-systemd/meta-oe/recipes-connectivity/dnsmasq/dnsmasq_2.55.bbappend b/meta-systemd/meta-oe/recipes-connectivity/dnsmasq/dnsmasq_2.55.bbappend
new file mode 100644
index 0000000000..0a9c77ec78
--- /dev/null
+++ b/meta-systemd/meta-oe/recipes-connectivity/dnsmasq/dnsmasq_2.55.bbappend
@@ -0,0 +1,10 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+PRINC := "${@int(PRINC) + 1}"
+
+inherit systemd
+
+SRC_URI += "file://dnsmasq.service"
+
+SYSTEMD_PACKAGES = "${PN}-systemd"
+SYSTEMD_SERVICE = "dnsmasq.service"