aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-08-04 20:05:32 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-08-08 09:02:31 +0200
commit6fd1caa623563f728d87434f5684cf1d3c9b6c53 (patch)
tree287331d566860e1d77062d04ccfc50609994de31 /meta-systemd
parentb0032dca6939259409f9ea3c925c3af2f757c0b0 (diff)
downloadmeta-openembedded-contrib-6fd1caa623563f728d87434f5684cf1d3c9b6c53.tar.gz
busybox-syslog.service.in: Create alias for syslog.service
The default syslog implementation should make syslog.service a symlink to itself, so that this socket activates the right actual syslog service. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in1
-rw-r--r--meta-systemd/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend2
2 files changed, 2 insertions, 1 deletions
diff --git a/meta-systemd/meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in b/meta-systemd/meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in
index c6c625ec52..2e04321385 100644
--- a/meta-systemd/meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in
+++ b/meta-systemd/meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in
@@ -10,3 +10,4 @@ Sockets=syslog.socket
[Install]
WantedBy=multi-user.target
Also=busybox-klogd.service
+Alias=syslog.service
diff --git a/meta-systemd/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend b/meta-systemd/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend
index 915a50ebf2..bb1155074f 100644
--- a/meta-systemd/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend
+++ b/meta-systemd/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend
@@ -1,6 +1,6 @@
inherit systemd
-PRINC := "${@int(PRINC) + 2}"
+PRINC := "${@int(PRINC) + 3}"
# look for files in the layer first
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"