aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorShakeel, Muhammad <muhammad_shakeel@mentor.com>2013-09-12 15:28:52 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-09-17 19:06:27 +0200
commitc837f8a883f1ff9aa6fd4a313b151e8967a1d9cc (patch)
tree319585b3f235f9386b8f6d17a5b65e705b17ff03 /meta-systemd
parent19a61e1f0cbe9e59b7de9f36106a2f9e32f880fa (diff)
downloadmeta-openembedded-contrib-c837f8a883f1ff9aa6fd4a313b151e8967a1d9cc.tar.gz
openssh: Remove systemd support which is merged in oe-core
OE-Core has been updated to support openssh with systemd. Stuff here is not required anymore. Signed-off-by: Muhammad Shakeel <muhammad_shakeel@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/openssh/openssh/sshd.socket11
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/openssh/openssh/sshd@.service9
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/openssh/openssh/sshdgenkeys.service10
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p2.bbappend16
4 files changed, 0 insertions, 46 deletions
diff --git a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh/sshd.socket b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh/sshd.socket
deleted file mode 100644
index 753a33b393..0000000000
--- a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh/sshd.socket
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Conflicts=sshd.service
-
-[Socket]
-ExecStartPre=/bin/mkdir -p /var/run/sshd
-ListenStream=22
-Accept=yes
-
-[Install]
-WantedBy=sockets.target
-Also=sshdgenkeys.service
diff --git a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh/sshd@.service b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh/sshd@.service
deleted file mode 100644
index d118490bdb..0000000000
--- a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh/sshd@.service
+++ /dev/null
@@ -1,9 +0,0 @@
-[Unit]
-Description=OpenSSH Per-Connection Daemon
-After=sshdgenkeys.service
-
-[Service]
-ExecStart=-/usr/sbin/sshd -i
-ExecReload=/bin/kill -HUP $MAINPID
-StandardInput=socket
-StandardError=syslog
diff --git a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh/sshdgenkeys.service b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh/sshdgenkeys.service
deleted file mode 100644
index c717214c55..0000000000
--- a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh/sshdgenkeys.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=SSH Key Generation
-
-[Service]
-ExecStart=/usr/bin/ssh-keygen -A
-Type=oneshot
-RemainAfterExit=yes
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p2.bbappend b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p2.bbappend
index d9ad9ba2a5..dadbc14991 100644
--- a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p2.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p2.bbappend
@@ -1,19 +1,3 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SYSTEMD_PACKAGES = "${PN}-sshd"
-SYSTEMD_SERVICE_${PN}-sshd = "sshd.socket"
-FILES_${PN}-sshd += "${systemd_unitdir}/system/sshd.socket"
RPROVIDES_${PN}-sshd += "${PN}-sshd-systemd"
RREPLACES_${PN}-sshd += "${PN}-sshd-systemd"
RCONFLICTS_${PN}-sshd += "${PN}-sshd-systemd"
-
-inherit systemd
-
-SRC_URI += "file://sshd.socket file://sshd@.service file://sshdgenkeys.service"
-do_install_append() {
- install -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/sshd.socket ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/sshd@.service ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/sshdgenkeys.service ${D}${systemd_unitdir}/system
-}
-