aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-10-20 23:32:05 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-26 10:28:39 +0200
commite63aa5b05686dc36c6729500f1c0aeef6c49de7e (patch)
tree40e7a4be79c03915ae74a2a40d22f86e17fb3dd2 /meta-systemd
parent51867d2826c8296db210fe69e508aeda29d9f17e (diff)
downloadmeta-openembedded-contrib-e63aa5b05686dc36c6729500f1c0aeef6c49de7e.tar.gz
dhcp_%.bbappend: fix replaces original key warning
Use ${PN} rather than dhcp to keep align with oe-core to fix: WARNING: oe-core/meta/recipes-connectivity/dhcp/dhcp_4.3.4.bb: Variable key SYSTEMD_AUTO_ENABLE_${PN}-client (enable) replaces original key SYSTEMD_AUTO_ENABLE_dhcp-client (disable). WARNING: oe-core/meta/recipes-connectivity/dhcp/dhcp_4.3.4.bb: Variable key SYSTEMD_SERVICE_${PN}-client (dhclient.service) replaces original key SYSTEMD_SERVICE_dhcp-client (dhclient.service). Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_%.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_%.bbappend b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_%.bbappend
index 94d7bd65e0..9c7d93f166 100644
--- a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_%.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_%.bbappend
@@ -2,8 +2,8 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SYSTEMD_PACKAGES += "dhcp-client"
-SYSTEMD_SERVICE_dhcp-client = "dhclient.service"
-SYSTEMD_AUTO_ENABLE_dhcp-client = "disable"
+SYSTEMD_SERVICE_${PN}-client = "dhclient.service"
+SYSTEMD_AUTO_ENABLE_${PN}-client = "disable"
FILES_${PN}-client += "${systemd_unitdir}/system/dhclient.service"
RPROVIDES_dhcp-server += "dhcp-server-systemd"