aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/recipes-core
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-08-07 23:04:24 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-08-08 09:07:39 +0200
commitd6408d879392f0fc9f44f6545a315a8cf6f51ebb (patch)
tree7d7dbbee43684fdc8e9987ef7e794487cd3fe6e2 /meta-systemd/recipes-core
parent7aa72413513d85b97b1ffff0ddb3cfd3ae68a8d0 (diff)
downloadmeta-openembedded-contrib-d6408d879392f0fc9f44f6545a315a8cf6f51ebb.tar.gz
systemd-systemctl-native: handle ALIAS tag
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd/recipes-core')
-rw-r--r--meta-systemd/recipes-core/systemd/systemd-systemctl-native.bb2
-rwxr-xr-xmeta-systemd/recipes-core/systemd/systemd-systemctl-native/systemctl17
2 files changed, 18 insertions, 1 deletions
diff --git a/meta-systemd/recipes-core/systemd/systemd-systemctl-native.bb b/meta-systemd/recipes-core/systemd/systemd-systemctl-native.bb
index 5f23e988eb..25ddbdadec 100644
--- a/meta-systemd/recipes-core/systemd/systemd-systemctl-native.bb
+++ b/meta-systemd/recipes-core/systemd/systemd-systemctl-native.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Wrapper to enable of systemd services"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-PR = "r4"
+PR = "r5"
inherit native
diff --git a/meta-systemd/recipes-core/systemd/systemd-systemctl-native/systemctl b/meta-systemd/recipes-core/systemd/systemd-systemctl-native/systemctl
index a5bd77085b..5c21e7f2ed 100755
--- a/meta-systemd/recipes-core/systemd/systemd-systemctl-native/systemctl
+++ b/meta-systemd/recipes-core/systemd/systemd-systemctl-native/systemctl
@@ -96,6 +96,23 @@ for service in $services; do
fi
done
+ # create the required symbolic 'Alias' links
+ alias=$(grep Alias $ROOT/$service_file \
+ | sed 's,Alias=,,g' \
+ | tr ',' '\n' \
+ | grep '\.service$')
+
+ for r in $alias; do
+ if [ "$action" = "enable" ]; then
+ mkdir -p $ROOT/etc/systemd/system
+ ln -s $service_file $ROOT/etc/systemd/system/$r
+ echo "Enabled $service for $alias."
+ else
+ rm -f $ROOT/etc/systemd/system/$r
+ echo "Disabled $service for $alias."
+ fi
+ done
+
# call us for the other required scripts
also=$(grep Also $ROOT/$service_file \
| sed 's,Also=,,g' \