aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-02-13 17:25:35 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-12 18:49:55 +0200
commit313f0ae25925caead4f588695ac9c9bcf00b2755 (patch)
tree1c167bd3cecfa253e438fefd045db110e2fa4cad /meta-systemd/oe-core/recipes-extended
parent0afa2a51d2720ed1d6c06aaef17bd90248ef650e (diff)
downloadmeta-openembedded-contrib-313f0ae25925caead4f588695ac9c9bcf00b2755.tar.gz
meta-systemd: Append ${PN} to SYSTEMD_SERVICE
When using systemd class from OE-Core we also need to install the units explicitly. systemd packages ending with -systemd are consumed and now provided by package proper. MJ: fix RPROVIDES_PN = PN-systemd in entrance MJ: add RPROVIDES for ntp*-systemd in ntp MJ: the same for wpa-supplicant Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd/oe-core/recipes-extended')
-rw-r--r--meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
index 0e08358b29..89079dcae1 100644
--- a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
+++ b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
@@ -7,4 +7,11 @@ inherit systemd
SRC_URI += "file://lighttpd.service"
SYSTEMD_PACKAGES = "${PN}"
+RPROVIDES_${PN} += "${PN}-systemd"
SYSTEMD_SERVICE_${PN} = "lighttpd.service"
+
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system
+}
+