aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core/recipes-core
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-12-03 23:31:32 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2012-12-11 01:52:56 +0100
commit8b4f56eda870c18f0bcd5650294ef240bada28ef (patch)
tree2ba07d6892404ea4579ecc9206e3e84808dc4959 /meta-systemd/oe-core/recipes-core
parent124a9515fdc842c8bf1cb66c68da615c7b6084af (diff)
downloadmeta-openembedded-contrib-8b4f56eda870c18f0bcd5650294ef240bada28ef.tar.gz
util-linux: add meta-systemd bbappend for new version which installs uuidd.service and socket
* fixes: util-linux-2.22.1: util-linux: Files/directories were installed but not shipped /lib/systemd /lib/systemd/system /lib/systemd/system/uuidd.socket /lib/systemd/system/uuidd.service Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd/oe-core/recipes-core')
-rw-r--r--meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.1.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.1.bbappend b/meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.1.bbappend
new file mode 100644
index 0000000000..809a554390
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.1.bbappend
@@ -0,0 +1,8 @@
+inherit systemd
+
+PRINC := "${@int(PRINC) + 1}"
+
+SYSTEMD_UNITDIR = "${systemd_unitdir}/system"
+EXTRA_OECONF += "--enable-socket-activation --with-systemdsystemunitdir=${SYSTEMD_UNITDIR}"
+SYSTEMD_PACKAGES = "${PN}-systemd"
+SYSTEMD_SERVICE = "uuidd.socket"