aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core/recipes-connectivity
diff options
context:
space:
mode:
authorSander van Grieken <sander@outrightsolutions.nl>2012-08-30 11:36:27 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-09-04 14:49:01 +0200
commit62884020d9119fea79dad44c9f62e4a01448c628 (patch)
tree6cd904f1fe69eabdf0061487f1b730182f264e41 /meta-systemd/oe-core/recipes-connectivity
parenta81cdc840c1dfca2bd0cb4ddd6e4bc1488286649 (diff)
downloadmeta-openembedded-contrib-62884020d9119fea79dad44c9f62e4a01448c628.tar.gz
avahi: use systemd.bbclass for avahi-systemd
The original behaviour is to enable the service in the package postinst phase. This patch will enable the service also when building the rootfs, so it fixes the case when no package-management is enabled. It also now delegates systemd enablement to the systemd bbclass, instead of using explicit code in the recipe itself. Signed-off-by: Sander van Grieken <sander@outrightsolutions.nl> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd/oe-core/recipes-connectivity')
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend b/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend
new file mode 100644
index 0000000000..d41ca93bfc
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend
@@ -0,0 +1,9 @@
+PRINC := "${@int(PRINC) + 1}"
+
+inherit systemd
+
+SYSTEMD_PACKAGES = "${PN}-systemd"
+SYSTEMD_SERVICE = "avahi-daemon.service"
+SYSTEMD_AUTO_ENABLE = "enable"
+
+FILES_${PN}-systemd += "${systemd_unitdir}/system/"