aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core/recipes-connectivity
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-12 13:32:33 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-12 18:50:15 +0200
commit1482cfe735de97eec6bc87cb653c92aef002bc10 (patch)
tree20fdc86810b01f2f461aa124b41baf172b54ece4 /meta-systemd/oe-core/recipes-connectivity
parentf195081bd0d52f72e0a8b54dc48d47624a1ebbbe (diff)
downloadmeta-openembedded-contrib-1482cfe735de97eec6bc87cb653c92aef002bc10.tar.gz
meta-systemd: bump PRINC in all .bbappends
* opkg upgrade will fail to upgrade every package PN when PN-system is installed * check_data_file_clashes: Package xserver-nodm-init wants to install file /lib/systemd/system/xserver-nodm.service But that file is already provided by package * xserver-nodm-init-systemd You need to manually remove all PN-systemd packages on your target opkg remove -force-depends -force-remove `opkg list-installed | grep "\-systemd"` be careful with stuff like openssh-sshd-systemd or wpa-supplicant-systemd when you have access to target only over network * this PRINC bump will force you to do it now even for people not using OEBasicHash or PR service Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd/oe-core/recipes-connectivity')
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend2
8 files changed, 8 insertions, 8 deletions
diff --git a/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend b/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend
index 987c510c3c..13a2ee453c 100644
--- a/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend
@@ -1,4 +1,4 @@
-PRINC := "${@int(PRINC) + 1}"
+PRINC := "${@int(PRINC) + 2}"
inherit systemd
diff --git a/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend b/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend
index e4dcabb3fe..752e6c1951 100644
--- a/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend
@@ -1,4 +1,4 @@
-PRINC := "${@int(PRINC) + 1}"
+PRINC := "${@int(PRINC) + 2}"
inherit systemd
diff --git a/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend b/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend
index 0ba99b5d83..96a428f1da 100644
--- a/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend
@@ -1,4 +1,4 @@
-PRINC := "${@int(PRINC) + 1}"
+PRINC := "${@int(PRINC) + 2}"
RPROVIDES_${PN} += "${PN}-systemd"
SYSTEMD_SERVICE_${PN} = "connman.service"
diff --git a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend
index aec1dfbe94..d3a322ae7f 100644
--- a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend
@@ -3,7 +3,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
inherit systemd
-PRINC := "${@int(PRINC) + 1}"
+PRINC := "${@int(PRINC) + 2}"
SYSTEMD_PACKAGES = "dhcp-server dhcp-relay dhcp-client"
SYSTEMD_SERVICE_dhcp-server = "dhcpd.service"
diff --git a/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend b/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend
index e0e8f28292..94fce48a55 100644
--- a/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend
@@ -1,4 +1,4 @@
-PRINC := "${@int(PRINC) + 1}"
+PRINC := "${@int(PRINC) + 2}"
inherit systemd
diff --git a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend
index fe5c919063..0d1bb56e85 100644
--- a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend
@@ -1,6 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-PRINC := "${@int(PRINC) + 1}"
+PRINC := "${@int(PRINC) + 2}"
SYSTEMD_PACKAGES = "openssh-sshd"
SYSTEMD_SERVICE_openssh-sshd = "sshd.socket"
diff --git a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
index 73709e8a61..784fc1f47c 100644
--- a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
@@ -1,6 +1,6 @@
FILESEXTRAPATHS := "${THISDIR}/${PN}"
-PRINC := "${@int(PRINC) + 1}"
+PRINC := "${@int(PRINC) + 2}"
inherit systemd
diff --git a/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend b/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
index d0ce87eb03..dcd9b84e8e 100644
--- a/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
@@ -1,3 +1,3 @@
-PRINC := "${@int(PRINC) + 3}"
+PRINC := "${@int(PRINC) + 4}"
RPROVIDES_${PN} += "${PN}-systemd"