aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p1.bbappend
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-29 10:36:11 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-29 10:37:32 +0200
commit48049a3627ac667d6383568d859bb1ea114a90b8 (patch)
tree8767a5079e3ddce92ccfc96665ea87e15849a96a /meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p1.bbappend
parenta0626bab8053a6378bb159cc8b318f7b0a659519 (diff)
downloadmeta-openembedded-contrib-48049a3627ac667d6383568d859bb1ea114a90b8.tar.gz
openssh: rename bbappend to match new version from oe-core
Diffstat (limited to 'meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p1.bbappend')
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p1.bbappend21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p1.bbappend b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p1.bbappend
new file mode 100644
index 0000000000..4789ad06fe
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p1.bbappend
@@ -0,0 +1,21 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+PRINC := "${@int(PRINC) + 3}"
+
+SYSTEMD_PACKAGES = "${PN}-sshd"
+SYSTEMD_SERVICE_${PN}-sshd = "sshd.socket"
+FILES_${PN}-sshd += "${systemd_unitdir}/system/sshd.socket"
+RPROVIDES_${PN}-sshd += "${PN}-sshd-systemd"
+RREPLACES_${PN}-sshd += "${PN}-sshd-systemd"
+RCONFLICTS_${PN}-sshd += "${PN}-sshd-systemd"
+
+inherit systemd
+
+SRC_URI += "file://sshd.socket file://sshd@.service file://sshdgenkeys.service"
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/sshd.socket ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/sshd@.service ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/sshdgenkeys.service ${D}${systemd_unitdir}/system
+}
+