aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ruby
diff options
context:
space:
mode:
authorBian Naimeng <biannm@cn.fujitsu.com>2015-06-18 14:27:24 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-06-23 12:41:53 +0200
commite48d73e842a236b4a76ab6761e1addc1f40fbd0b (patch)
treeaae71eb4fa2462698984727e5bdf0e3f19b65d1e /meta-ruby
parente9ea7bed891373c4bf767daa7e8bac3891122f1b (diff)
downloadmeta-openembedded-contrib-e48d73e842a236b4a76ab6761e1addc1f40fbd0b.tar.gz
imsettings: add new recipe
imsettings is a delivery framework for general input-method configuration Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-ruby')
-rw-r--r--meta-ruby/recipes-extended/imsettings/imsettings/gtk-is-required-by-notify.patch18
-rw-r--r--meta-ruby/recipes-extended/imsettings/imsettings_1.6.8.bb29
2 files changed, 47 insertions, 0 deletions
diff --git a/meta-ruby/recipes-extended/imsettings/imsettings/gtk-is-required-by-notify.patch b/meta-ruby/recipes-extended/imsettings/imsettings/gtk-is-required-by-notify.patch
new file mode 100644
index 0000000000..d42358d690
--- /dev/null
+++ b/meta-ruby/recipes-extended/imsettings/imsettings/gtk-is-required-by-notify.patch
@@ -0,0 +1,18 @@
+gtk+ is required by linnotify. So make sure gtk be linked before libnotify
+
+Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com>
+
+diff -Nurp imsettings-1.6.7.orig/configure.ac imsettings-1.6.7/configure.ac
+--- imsettings-1.6.7.orig/configure.ac 2013-11-26 16:09:09.000000000 +0800
++++ imsettings-1.6.7/configure.ac 2014-12-30 11:27:44.370003209 +0800
+@@ -93,8 +93,8 @@ PKG_CHECK_MODULES(LIBNOTIFY, libnotify,
+ has_old_libnotify=yes
+ PKG_CHECK_MODULES(GTK, gtk+-2.0 >= $GTK_REQUIRED)
+ AC_DEFINE(HAS_OLD_LIBNOTIFY,, [Using older libnotify])
+- IMDAEMON_CFLAGS="$GTK_CFLAGS $LIBNOTIFY_OLD_CFLAGS"
+- IMDAEMON_LIBS="$GTK_LIBS $LIBNOTIFY_OLD_LIBS"],[
++ IMDAEMON_CFLAGS="$LIBNOTIFY_OLD_CFLAGS $GTK_CFLAGS"
++ IMDAEMON_LIBS="$LIBNOTIFY_OLD_LIBS $GTK_LIBS"],[
+ has_old_libnotify=no
+ IMDAEMON_CFLAGS="$LIBNOTIFY_CFLAGS"
+ IMDAEMON_LIBS="$LIBNOTIFY_LIBS"])
diff --git a/meta-ruby/recipes-extended/imsettings/imsettings_1.6.8.bb b/meta-ruby/recipes-extended/imsettings/imsettings_1.6.8.bb
new file mode 100644
index 0000000000..91443d7b6e
--- /dev/null
+++ b/meta-ruby/recipes-extended/imsettings/imsettings_1.6.8.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Delivery framework for general Input Method configuration"
+DESCRIPTION = "IMSettings is a framework that delivers Input Method \
+settings and applies the changes so they take effect \
+immediately without any need to restart applications \
+or the desktop. \
+This package contains the core DBus services and some utilities."
+HOMEPAGE = "http://code.google.com/p/imsettings/"
+SECTION = "Applications/System"
+
+inherit autotools gtk-doc
+
+SRC_URI = "https://bitbucket.org/tagoh/imsettings/downloads/${BPN}-${PV}.tar.bz2 \
+ file://gtk-is-required-by-notify.patch"
+
+SRC_URI[md5sum] = "c31429f1d60e36d7f811f871c75b6c41"
+SRC_URI[sha256sum] = "2620ffbf9a6dc842dbf994b4773d4fe355eb77076ccf33f726ba63f16c0d08ba"
+
+LICENSE = "LGPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+EXTRA_OECONF = "--with-xinputsh=50-xinput.sh \
+ --disable-static \
+ "
+
+DEPENDS = "gtk+ gconf libnotify dbus-glib libgxim"
+
+RDEPENDS_${PN} += "bash"
+
+FILES_${PN} += "${datadir}/dbus-1/*"