aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-08 12:28:10 +0200
committerKhem Raj <raj.khem@gmail.com>2021-01-12 09:15:10 -0800
commit0fa3f8366b44dfb90ed8d046b72e122c13951563 (patch)
tree13044c42d211cce471a883004b14850929ad23b8 /meta-python
parentc7a154b01ec7eca2bb87276bf6ee86087f2ed686 (diff)
downloadmeta-openembedded-contrib-0fa3f8366b44dfb90ed8d046b72e122c13951563.tar.gz
python3-aiohttp: Upgrade 3.7.2 -> 3.7.3
Upgrade to release 3.7.3: - Use Brotli instead of brotlipy - Made exceptions pickleable. Also changed the repr of some exceptions. - Raise a ClientResponseError instead of an AssertionError for a blank HTTP Reason Phrase. - Fix web_middlewares.normalize_path_middleware behavior for patch without slash. - Fix overshadowing of overlapped sub-applications prefixes. - Make BaseConnector.close() a coroutine and wait until the client closes all connections. Drop deprecated "with Connector():" syntax. - Reset the sock_read timeout each time data is received for a aiohttp.client response. - Fixed type annotation for add_view method of UrlDispatcher to accept any subclass of View - Fixed querying the address families from DNS that the current host supports. - Change return type of MultipartReader.aiter() and BodyPartReader.aiter() to AsyncIterator. - Provide x86 Windows wheels. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-aiohttp_3.7.3.bb (renamed from meta-python/recipes-devtools/python/python3-aiohttp_3.7.2.bb)3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aiohttp_3.7.2.bb b/meta-python/recipes-devtools/python/python3-aiohttp_3.7.3.bb
index c98e3aee7a..bccbd4b0e9 100644
--- a/meta-python/recipes-devtools/python/python3-aiohttp_3.7.2.bb
+++ b/meta-python/recipes-devtools/python/python3-aiohttp_3.7.3.bb
@@ -4,8 +4,7 @@ HOMEPAGE = "https://github.com/aio-libs/aiohttp"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3bf3d48554bdca1ea7fdb48de378c2ca"
-SRC_URI[md5sum] = "dcf770341241aa09340653a1562ca816"
-SRC_URI[sha256sum] = "c6da1af59841e6d43255d386a2c4bfb59c0a3b262bdb24325cc969d211be6070"
+SRC_URI[sha256sum] = "9c1a81af067e72261c9cbe33ea792893e83bc6aa987bfbd6fdc1e5e7b22777c4"
PYPI_PACKAGE = "aiohttp"
inherit setuptools3 pypi