aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-12-22 13:02:51 +0800
committerKhem Raj <raj.khem@gmail.com>2021-01-04 14:48:29 -0800
commit0f7cc1eeae774f5b25c42c6e3982ff6bb731b874 (patch)
tree3e9dbf1f907ddd9e3ff36a8f9c3ba944be54278c /meta-python
parentd9f3b767a261dda1a56e1c97cb8fc8ac1bf4b33f (diff)
downloadmeta-openembedded-contrib-0f7cc1eeae774f5b25c42c6e3982ff6bb731b874.tar.gz
python3-cachetools: upgrade 4.1.1 -> 4.2.0
v4.2.0 (2020-12-10) =================== - Add FIFO cache implementation. - Add MRU cache implementation. - Improve behavior of decorators in case of race conditions. - Improve documentation regarding mutability of caches values and use of key functions with decorators. - Officially support Python 3.9. The ptest log is as follows: START: ptest-runner 2020-12-22T02:58 BEGIN: /usr/lib/python3-cachetools/ptest ============================= test session starts ============================== platform linux -- Python 3.9.0, pytest-6.1.2, py-1.9.0, pluggy-0.13.1 rootdir: /usr/lib/python3-cachetools/ptest collected 164 items ... ============================= 164 passed in 12.95s ============================= DURATION: 21 END: /usr/lib/python3-cachetools/ptest 2020-12-22T02:58 STOP: ptest-runner Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-cachetools_4.2.0.bb (renamed from meta-python/recipes-devtools/python/python3-cachetools_4.1.1.bb)8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cachetools_4.1.1.bb b/meta-python/recipes-devtools/python/python3-cachetools_4.2.0.bb
index d334070cdb..cc697d5a95 100644
--- a/meta-python/recipes-devtools/python/python3-cachetools_4.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-cachetools_4.2.0.bb
@@ -14,6 +14,10 @@ SRC_URI += " \
file://run-ptest \
"
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-math \
+"
+
RDEPENDS_${PN}-ptest += " \
${PYTHON_PN}-pytest \
"
@@ -23,7 +27,7 @@ do_install_ptest() {
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
}
-SRC_URI[md5sum] = "ae41b69896f49727e1621d279cb72522"
-SRC_URI[sha256sum] = "bbaa39c3dede00175df2dc2b03d0cf18dd2d32a7de7beb68072d13043c9edb20"
+SRC_URI[md5sum] = "9d54dacd774e2af7e9a50741386f5455"
+SRC_URI[sha256sum] = "3796e1de094f0eaca982441c92ce96c68c89cced4cd97721ab297ea4b16db90e"
BBCLASSEXTEND = "native nativesdk"